Bug 153236 - mod_perl: update and specfile cleanup
mod_perl: update and specfile cleanup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-04-03 17:24 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 05:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update and specfile cleanup (5.93 KB, patch)
2005-04-03 17:24 EDT, Jose Pedro Oliveira
no flags Details | Diff
Full specfile (13.55 KB, text/plain)
2005-04-04 09:51 EDT, Jose Pedro Oliveira
no flags Details
mod_perl 2.0.0 rc5 specfile patch (816 bytes, patch)
2005-04-17 10:30 EDT, Jose Pedro Oliveira
no flags Details | Diff
Filter requirements update (604 bytes, patch)
2005-04-18 19:05 EDT, Jose Pedro Oliveira
no flags Details | Diff

  None (edit)
Description Jose Pedro Oliveira 2005-04-03 17:24:37 EDT
Version-Release number of selected component (if applicable):
1.99_17-2

Expected results:
2.0.0-RC4

Additional info:
Patch included.

Known problems:
- the test suite is protected by a non-existent arch (%ifarch 1386)
- the test suite fails (mod_perl 1.99_17 and 2.0.0-rc4)
  I think is only file/directories permissions problems. I will try to
  look at it in a few days.

Related bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=151178
Comment 1 Jose Pedro Oliveira 2005-04-03 17:24:38 EDT
Created attachment 112638 [details]
Update and specfile cleanup
Comment 2 Joe Orton 2005-04-04 09:05:06 EDT
Thanks Jose, any chance you could submit a patch without all the whitespace
changes - it makes it hard to review?

(I prefer non-vertically-aligned field values in spec files, anyway ;)
Comment 3 Michael Schwendt 2005-04-04 09:14:36 EDT
"diff -bu" (-b ignores changes in amount of white-space)
Comment 4 Jose Pedro Oliveira 2005-04-04 09:51:29 EDT
Created attachment 112649 [details]
Full specfile

Joe Orton,

Attaching the full specfile.  The specfile is using the Fedora.us and
Fedora.Extras template.

If you still want I can redo the specfile but only at the end of the afternoon
(5 hours).

jpo
Comment 5 Jose Pedro Oliveira 2005-04-06 12:54:27 EDT
Joe Orton,

Have you already made the update? Or do you still want me to rediff the patch?

jpo
Comment 6 Joe Orton 2005-04-11 09:23:39 EDT
Sorry for the delay, I was out for a couple of days.  It's not the most helpful
to attach full updated specfiles; the best thing to do is to attach a diff
against the /devel/ spec file from CVS (again, without all the whitespace
changes); this way I can review the changes easily.
Comment 7 Warren Togami 2005-04-14 16:44:52 EDT
Joe mind if I handle this report?  I'll personally review and test all changes.
Comment 8 Joe Orton 2005-04-14 16:57:05 EDT
Sure, go ahead!
Comment 9 Warren Togami 2005-04-17 02:18:11 EDT
http://people.redhat.com/wtogami/temp/mod_perl.spec
upgraded to RC5
excluded INSTALL because it is useless build instructions

http://people.redhat.com/wtogami/temp/mod_perl-555857-x86_64-crowe.devel.redhat.com.log
Everything seems good except lib64...
Comment 10 Jose Pedro Oliveira 2005-04-17 10:30:34 EDT
Created attachment 113290 [details]
mod_perl 2.0.0 rc5 specfile patch
Comment 11 Jose Pedro Oliveira 2005-04-17 10:36:44 EDT
Warren,

The mod_perl 2.0.0 rc5 build should also have failed in i386 as several files
have been renamed (Apache:: -> Apache2::).  Files in the new Apache2 namespace
weren't being included in the %files section.

Patch: previous comment


*Very important* note from the mod_perl 2.0.0 rc5 (1.999_22) changelog:
----------
1.999_22

    ******************** IMPORTANT ********************
    this version of mod_perl is completely incompatible
      with prior versions of mod_perl, both 1.XX and
     1.99_XX. Please read the below changes carefully.
    ***************************************************
   ...
----------
Source: http://search.cpan.org/~geoff/mod_perl-2.0.0-RC5/Changes

Can this warning be added to the FC4 release notes?

jpo

Comment 12 Warren Togami 2005-04-17 17:35:28 EDT
http://cvs.fedora.redhat.com/viewcvs/fedora-release/?root=fedora
/cvs/fedora is where you can check this out and fix it yourself, I think.
Comment 13 Jose Pedro Oliveira 2005-04-18 19:05:00 EDT
Created attachment 113349 [details]
Filter requirements update

Warren,

Trying to install mod_perl-2.0.0-0.rc5.1 gives the following messages:
---
  perl(Apache2::FunctionTable) is needed by mod_perl-2.0.0-0.rc5.1.i386
  perl(Apache2::StructureTable) is needed by mod_perl-2.0.0-0.rc5.1.i386
---

The filter needs to be updated as several perl modules were renamed in RC5.
The patch corrects the problem.
Comment 14 Jose Pedro Oliveira 2005-04-18 19:14:11 EDT
Ignore previous comment and patch.
Already in CVS (2.0.0-0.rc5.2).
Comment 15 Warren Togami 2005-04-27 05:41:32 EDT
Fixed in perl main package.

Note You need to log in before you can comment on or make changes to this bug.