Bug 1532577 - [RFE] allow lease selection in custom preview of a snapshot
Summary: [RFE] allow lease selection in custom preview of a snapshot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.2
: ---
Assignee: Eyal Shenitzky
QA Contact: Evelina Shames
URL:
Whiteboard:
Depends On: 1484863
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-09 11:40 UTC by Eyal Shenitzky
Modified: 2018-03-29 11:15 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.2.2.1
Doc Type: If docs needed, set a value
Doc Text:
Until this fix, there was no way to select specific lease to use while previewing a snapshot. After this fix, the user can select whether he wants to preview the snapshot with a lease and to specify the specific lease. The user can perform the custom preview of a snapshot and select the specific lease via REST-API or via the UI.
Clone Of:
Environment:
Last Closed: 2018-03-29 11:15:02 UTC
oVirt Team: Storage
Embargoed:
amureini: ovirt-4.2?
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 86227 0 master MERGED restapi: Add lease parameter to preview snapshot 2018-01-23 15:41:22 UTC
oVirt gerrit 86228 0 master MERGED core: Allow lease selection in a snapshot custom preview 2018-02-18 17:39:47 UTC
oVirt gerrit 86513 0 master MERGED webadmin: Allow lease selection in custom preview 2018-02-18 17:39:50 UTC
oVirt gerrit 86713 0 model_4.2 MERGED restapi: Add lease parameter to preview snapshot 2018-01-23 16:43:14 UTC
oVirt gerrit 87308 0 master MERGED restapi: Update to model 4.3.7 2018-02-08 08:53:15 UTC
oVirt gerrit 87309 0 ovirt-engine-4.2 MERGED restapi: Update to model 4.2.29 2018-02-08 10:43:15 UTC
oVirt gerrit 87364 0 sdk_4.2 MERGED Update to model 4.2.29 and metamodel to 1.2.17 2018-02-08 18:59:33 UTC
oVirt gerrit 87825 0 ovirt-engine-4.2 MERGED core: Allow lease selection in a snapshot custom preview 2018-02-20 09:29:10 UTC
oVirt gerrit 87826 0 ovirt-engine-4.2 MERGED webadmin: Allow lease selection in custom preview 2018-02-20 10:37:23 UTC

Description Eyal Shenitzky 2018-01-09 11:40:51 UTC
Description of problem:

Currently, there is no treatment for snapshot-lease integration.
But after bug - 1484863 will be fixed, Preview / Undo / Commit operations will fail if the VM or the previewed snapshot has a lease and if the lease operations (create/remove) fails.

The engine should have the ability to allow costume preview which gives the option to choose whether the preview should contain the lease or not.
In this way, the user can preview a snapshot even if there is a failure that caused by the lease operations.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Eyal Shenitzky 2018-01-21 07:42:57 UTC
Implement in the UI and in the REST-API.

Comment 2 Allon Mureinik 2018-02-08 10:45:26 UTC
Not all the patches are merged, returning to POST

Comment 3 Evelina Shames 2018-02-26 14:20:10 UTC
Verified.

Comment 4 Sandro Bonazzola 2018-03-29 11:15:02 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.