Bug 1532586 - _CGROUP_CONTROLLER_MASK_ALL does not cover CGROUP_PIDS [NEEDINFO]
Summary: _CGROUP_CONTROLLER_MASK_ALL does not cover CGROUP_PIDS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
: 1539024 (view as bug list)
Depends On:
Blocks: 1186913 1523043 1544748
TreeView+ depends on / blocked
 
Reported: 2018-01-09 11:57 UTC by Lukáš Nykrýn
Modified: 2019-09-11 18:05 UTC (History)
12 users (show)

Fixed In Version: systemd-219-53.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1544748 (view as bug list)
Environment:
Last Closed: 2018-04-10 11:25:34 UTC
apevec: needinfo? (systemd-maint)
toneata: needinfo? (bbreard)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0711 None None None 2018-04-10 11:26:25 UTC

Description Lukáš Nykrýn 2018-01-09 11:57:36 UTC
Problem is that this hunk
diff --git a/src/shared/cgroup-util.h b/src/shared/cgroup-util.h
index 96a3d3baf..31bd8d311 100644
--- a/src/shared/cgroup-util.h
+++ b/src/shared/cgroup-util.h
@@ -35,6 +35,7 @@ typedef enum CGroupControllerMask {
         CGROUP_BLKIO = 4,
         CGROUP_MEMORY = 8,
         CGROUP_DEVICE = 16,
+        CGROUP_PIDS = 32,
         _CGROUP_CONTROLLER_MASK_ALL = 31
 } CGroupControllerMask;
 

Added a CGROUP_PIDS but did not bump _CGROUP_CONTROLLER_MASK_ALL.
This cause issues for example for OpenStack.

https://bugzilla.redhat.com/show_bug.cgi?id=1523043
https://github.com/lnykryn/systemd-rhel/issues/180

Comment 3 Lukáš Nykrýn 2018-01-09 13:22:36 UTC
fix merged to staging branch -> https://github.com/lnykryn/systemd-rhel/pull/181 -> post

Comment 16 errata-xmlrpc 2018-04-10 11:25:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0711

Comment 17 Derrick Ornelas 2019-09-11 18:05:30 UTC
*** Bug 1539024 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.