Bug 1532935 - hard hang when connecting HDMI display to USB-C port
Summary: hard hang when connecting HDMI display to USB-C port
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-10 02:54 UTC by Peter F. Patel-Schneider
Modified: 2018-02-20 21:18 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-20 21:18:53 UTC


Attachments (Terms of Use)

Description Peter F. Patel-Schneider 2018-01-10 02:54:53 UTC
Description of problem:  

I have a new Lenovo Yoga 920 with an Intel Corporation JHL6540 chip driving
two USC Type-C ports with Thunderbolt 3 and DisplayPort alternate modes.
When I plug in a USB Type-C to HDMI adapter (a TECHDOTY USB Type C to HDMI
Adapter Cable) and an HDMI display I sometimes get the display set up
correctly, using, I think, the DisplayPort alternate mode.

However sometimes this produces a hard hang.  I have to power-cycle the
laptop to recover.  When the laptop is hung it remains cool and the fans are
off, indicating that no heavy-duty computing is going on.  No output is
produced in the system log on reboot to indicate what went wrong.


Version-Release number of selected component (if applicable):

4.14.11-300.fc27.x86_64 #1 SMP Wed Jan 3 13:52:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

About half the time.

Steps to Reproduce:
1. Plug USB-C to HDMI adapter with HDMI display attached to USB-C port


Actual results:

The problematic result is a hard hang, requiring a power-off with the power button.

Expected results:

The normal result is a connected HDMI monitor.


Additional info:

PS:  How can I tell whether my USB-C ports are in Thunderbolt 3 or DisplayPort
mode?

Comment 1 Laura Abbott 2018-02-20 19:53:22 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  As kernel maintainers, we try to keep up with bugzilla but due the rate at which the upstream kernel project moves, bugs may be fixed without any indication to us. Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.
 
Fedora 27 has now been rebased to 4.15.3-300.f27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you experience different issues, please open a new bug report for those.

Comment 2 Peter F. Patel-Schneider 2018-02-20 21:18:53 UTC
I haven't seen this since I changed to 4.15 a couple of weeks ago, but I haven't been using an external HDMI monitor much.   I'll close this (for now, at least).


Note You need to log in before you can comment on or make changes to this bug.