Bug 1533313 - Failed to deploy logging
Summary: Failed to deploy logging
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.7.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-11 02:42 UTC by Anping Li
Modified: 2018-04-05 09:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
As part of an enhancement we no longer use a config trigger for ES and instead rollout in a handler. The handler was watching the old ES pod to see if the ES cluster was green/yellow
Clone Of:
Environment:
Last Closed: 2018-04-05 09:34:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:35:02 UTC

Description Anping Li 2018-01-11 02:42:23 UTC
Description of problem:
deploy logging failed using openshift-ansible:v3.7.22

Version-Release number of selected component (if applicable):
openshift-ansible-3.7.22-1.git.0.a938a52.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.deploy logging
2.
3.

Actual results:
TASK [openshift_logging : include_role] ****************************************
task path: /usr/share/ansible/openshift-ansible/roles/openshift_logging/tasks/install_logging.yaml:102
statically included: /usr/share/ansible/openshift-ansible/roles/openshift_logging_elasticsearch/tasks/determine_version.yaml
ERROR! no action detected in task. This often indicates a misspelled module name, or incorrect module path.

The error appears to have been in '/usr/share/ansible/openshift-ansible/roles/openshift_logging_elasticsearch/handlers/main.yml': line 2, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

---
- name: "Restarting logging-{{ _cluster_component }} cluster"
  ^ here
We could be wrong, but this one looks like it might be an issue with
missing quotes.  Always quote template expression brackets when they
start a value. For instance:

    with_items:
      - {{ foo }}

Should be written as:

    with_items:
      - "{{ foo }}"


The error appears to have been in '/usr/share/ansible/openshift-ansible/roles/openshift_logging_elasticsearch/handlers/main.yml': line 2, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

---
- name: "Restarting logging-{{ _cluster_component }} cluster"
  ^ here
We could be wrong, but this one looks like it might be an issue with
missing quotes.  Always quote template expression brackets when they
start a value. For instance:

Expected results:


Additional info:

Comment 5 Jeff Cantrill 2018-01-12 13:35:42 UTC
@Eric,

Is this a change related to the restart logic you were recently working with?  Is it something that was backported?

Comment 6 ewolinet 2018-01-12 15:07:19 UTC
Can you please provide the full log output with -vvv verbosity?
That error is misleading and doesn't seem to be indicative of what is actually going on.

I remember seeing something like that when first testing this for master but resolved it, I believe it was due to the handler running twice for some reason which is why https://github.com/openshift/openshift-ansible/blob/a938a5208ae39b9d14879c07ada1922154645dcc/roles/openshift_logging_elasticsearch/handlers/main.yml#L11-L13 was added.

Comment 7 Jeff Cantrill 2018-01-12 16:13:28 UTC
We believe this is resolved.  Please retest with the version of openshift-ansible in #c3 or later

Comment 8 Junqi Zhao 2018-01-15 02:10:14 UTC
Tested with openshift-ansible-playbooks-3.7.23-1.git.0.bc406aa.el7.noarch, logging can be deployed successfully now.

Comment 12 errata-xmlrpc 2018-04-05 09:34:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.