Bug 1533669 - cloud_name parameter is not created for custom networks
Summary: cloud_name parameter is not created for custom networks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Bob Fournier
QA Contact: mlammon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-11 23:18 UTC by Bob Fournier
Modified: 2018-06-27 13:42 UTC (History)
2 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180227121938.e0f59ee.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:42:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1740953 None None None 2018-01-11 23:19:58 UTC
OpenStack gerrit 532994 None MERGED Set cloud_name hiera parameter for composable networks 2020-08-31 05:20:49 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:42:55 UTC

Description Bob Fournier 2018-01-11 23:18:33 UTC
Description of problem: 
When using composable networks and adding a custom network the cloud_name parameter is not created for that network.

A jinja loop needs to be added to all-nodes-config.j2.yaml.


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.3-17.el7ost.noarch

How reproducible:
Every time.


Steps to Reproduce:
1. Deploy an overcloud.
2. ssh to the controller node
3. Check for cloud_name parameters for the networks

[heat-admin@overcloud-controller-0 ~]$ sudo grep -r cloud_name /var/lib/./config-data/haproxy/etc/puppet/hieradata
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_ctlplane": "overcloud.ctlplane.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_external": "overcloud.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_internal_api": "overcloud.internalapi.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_storage": "overcloud.storage.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_storage_mgmt": "overcloud.storagemgmt.localdomain",

Actual results:
no parameter for new OcProvisioning network.


Expected results:
Should be a cloud_name parameter.


Additional info:

Comment 3 mlammon 2018-05-15 15:08:08 UTC
Verify using puddle : 2018-04-10.2

Env:
(undercloud) [stack@host01 ~]$ rpm -q openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-8.0.2-0.20180327213846.el7ost.noarch

There is a composable role defined in network_data.yaml
(undercloud) [stack@host01 ~]$ tail -9 network_data.yaml
- name: OcProvisioning
  name_lower: oc_provisioning
  vip: true
  vlan: 205
  ip_subnet: '172.21.2.0/24'
  allocation_pools: [{'start': '172.21.2.10', 'end': '172.21.2.200'}]
  ipv6_subnet: 'fd00:fd00:fd00:7000::/64'
  ipv6_allocation_pools: [{'start': 'fd00:fd00:fd00:7000::10', 'end': 'fd00:fd00:fd00:7000:ffff:ffff:ffff:fffe'}]


[root@overcloud-controller-0 ~]# sudo grep -r cloud_name /var/lib/./config-data/haproxy/etc/puppet/hieradata
/var/lib/./config-data/haproxy/etc/puppet/hieradata/service_configs.json:    "neutron::agents::metadata::metadata_host": "%{hiera('cloud_name_internal_api')}",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_ctlplane": "overcloud.ctlplane.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_external": "overcloud.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_internal_api": "overcloud.internalapi.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_oc_provisioning": "overcloud.ocprovisioning.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_storage": "overcloud.storage.localdomain",
/var/lib/./config-data/haproxy/etc/puppet/hieradata/vip_data.json:    "cloud_name_storage_mgmt": "overcloud.storagemgmt.localdomain",

Comment 5 errata-xmlrpc 2018-06-27 13:42:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.