Bug 1533852 - Improve ERROR msg when LRO is not supported
Summary: Improve ERROR msg when LRO is not supported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ondřej Lysoněk
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-12 11:33 UTC by Tereza Cerna
Modified: 2019-08-06 13:05 UTC (History)
5 users (show)

Fixed In Version: tuned-2.11.0-0.1.rc1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:04:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github redhat-performance tuned pull 135 None None None 2018-11-21 10:26:06 UTC
Red Hat Product Errata RHBA-2019:2201 None None None 2019-08-06 13:05:15 UTC

Description Tereza Cerna 2018-01-12 11:33:08 UTC
Description of problem:
=======================
Improve error message for sap-hana-vmware profile when LRO is not supported. When I wanted to set LRO for eth0 and I didn't know that LRO is not supported, current error message didn't help me for understanding situation.

Version-Release number of selected component (if applicable):
=============================================================
tuned-2.9.0-1.el7.noarch
tuned-profiles-sap-hana-2.9.0-1.el7.noarch

How reproducible:
=================
Always when LRO (large-receive-offload) is not supported.

Steps to Reproduce:
===================
# cat /etc/tuned/sap-hana-vmware-variables.conf 
sap_hana_vmware_nic=eno1
# tuned-adm profile sap-hana-vmware
# cat /var/log/tuned/tuned.log
...
2018-01-12 12:10:23,619 ERROR    tuned.plugins.plugin_net: unable to save previous features, wanted to save: '['lro']', but read: '[('tx-vlan-offload', 'on'), ('tx-nocache-copy', 'off'), ('tcp-segmentation-offload', 'on'), ('\ttx-tcp-segmentation', 'on'), ('rx-vlan-offload', 'on'), ('tx-checksumming', 'on'), ('receive-hashing', 'on'), ('rx-all', 'off'), ('generic-receive-offload', 'on'), ('generic-segmentation-offload', 'on'), ('\ttx-tcp6-segmentation', 'on'), ('\ttx-checksum-ip-generic', 'on'), ('\ttx-scatter-gather', 'on'), ('rx-fcs', 'off'), ('scatter-gather', 'on'), ('\ttx-tcp-mangleid-segmentation', 'off'), ('rx-checksumming', 'on')]'
...

Following means that LRO is not supported:

# ethtool -K eno1 lro on
Cannot change large-receive-offload
Could not change any device features
# ethtool -k eno1  | grep large
large-receive-offload: off [fixed]          

Actual results:
===============
Error which is not so much understandable for user.

2018-01-12 12:10:23,619 ERROR    tuned.plugins.plugin_net: unable to save previous features, wanted to save: '['lro']', but read: '[('tx-vlan-offload', 'on'), ('tx-nocache-copy', 'off'), ('tcp-segmentation-offload', 'on'), ('\ttx-tcp-segmentation', 'on'), ('rx-vlan-offload', 'on'), ('tx-checksumming', 'on'), ('receive-hashing', 'on'), ('rx-all', 'off'), ('generic-receive-offload', 'on'), ('generic-segmentation-offload', 'on'), ('\ttx-tcp6-segmentation', 'on'), ('\ttx-checksum-ip-generic', 'on'), ('\ttx-scatter-gather', 'on'), ('rx-fcs', 'off'), ('scatter-gather', 'on'), ('\ttx-tcp-mangleid-segmentation', 'off'), ('rx-checksumming', 'on')]'

Expected results:
=================
Something more readable:

ERROR: LRO is not supported

Comment 2 Jaroslav Škarvada 2018-01-12 12:13:44 UTC
# ethtool -k eno1  | grep large
large-receive-offload: off [fixed]

IMHO the '[fixed]' is indicator that it's not supported. Tuned should check for it.

Comment 7 errata-xmlrpc 2019-08-06 13:04:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2201


Note You need to log in before you can comment on or make changes to this bug.