Bug 1534300 - [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
Summary: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-14 22:49 UTC by Filipe Rosset
Modified: 2018-01-18 23:12 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-18 23:12:08 UTC


Attachments (Terms of Use)
dmesg with kernel 4.15.0-0.rc8.git0.1.fc28.x86_64 (125.91 KB, text/plain)
2018-01-16 23:04 UTC, Filipe Rosset
no flags Details

Description Filipe Rosset 2018-01-14 22:49:14 UTC
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)

Hardware name: Apple Inc. MacBook4,1/Mac-F22788A9, BIOS     MB41.88Z.00C1.B00.0802091535 02/09/08

issue during startup, taking ~2 minutes to boot-up.

[   15.327202] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   15.428147] ------------[ cut here ]------------
[   15.428196] vblank wait timed out on crtc 0
[   15.428280] WARNING: CPU: 0 PID: 103 at drivers/gpu/drm/drm_vblank.c:1071 drm_wait_one_vblank+0x1a4/0x1b0 [drm]
[   15.428320] Modules linked in: i915 firewire_ohci ata_generic firewire_core pata_acpi crc_itu_t i2c_algo_bit drm_kms_helper
 hid_appleir sky2 drm video hid_apple
[   15.428413] CPU: 0 PID: 103 Comm: kworker/u4:4 Not tainted 4.15.0-0.rc7.git2.1.fc28.x86_64 #1
[   15.428448] Hardware name: Apple Inc. MacBook4,1/Mac-F22788A9, BIOS     MB41.88Z.00C1.B00.0802091535 02/09/08
[   15.428492] Workqueue: events_unbound async_run_entry_fn
[   15.428529] RIP: 0010:drm_wait_one_vblank+0x1a4/0x1b0 [drm]
[   15.428553] RSP: 0018:ffffbc3d40c8f9f0 EFLAGS: 00010282
[   15.428578] RAX: 0000000000000000 RBX: ffff9c4033240000 RCX: 0000000000000006
[   15.428607] RDX: 0000000000000007 RSI: ffff9c403490c000 RDI: ffff9c403b3d6c00
[   15.428636] RBP: 0000000000000000 R08: 0000000000000001 R09: 0000000000000000
[   15.428665] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000000
[   15.428694] R13: 0000000000000000 R14: 0000000001000001 R15: ffff9c4033df1808
[   15.428724] FS:  0000000000000000(0000) GS:ffff9c403b200000(0000) knlGS:0000000000000000
[   15.428757] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[   15.428782] CR2: 00007f4fcf331000 CR3: 000000011b412000 CR4: 00000000000006f0
[   15.428811] Call Trace:
[   15.428829]  ? finish_wait+0x80/0x80
[   15.428927]  intel_get_load_detect_pipe+0x56f/0x5f0 [i915]
[   15.429006]  intel_tv_detect+0x145/0x4c0 [i915]
[   15.429069]  ? drm_helper_probe_single_connector_modes+0xde/0x6e0 [drm_kms_helper]
[   15.429101]  drm_helper_probe_single_connector_modes+0xde/0x6e0 [drm_kms_helper]
[   15.429101]  drm_setup_crtcs+0x166/0xc50 [drm_kms_helper]
[   15.429101]  __drm_fb_helper_initial_config_and_unlock+0x39/0x480 [drm_kms_helper]
[   15.429101]  intel_fbdev_initial_config+0x14/0x30 [i915]
[   15.429101]  async_run_entry_fn+0x33/0x160
[   15.429101]  process_one_work+0x243/0x6b0
[   15.429101]  worker_thread+0x3a/0x390
[   15.429101]  ? process_one_work+0x6b0/0x6b0
[   15.429101]  kthread+0x11f/0x140
[   15.429101]  ? kthread_create_worker_on_cpu+0x70/0x70
[   15.429101]  ret_from_fork+0x24/0x30
[   15.429101] Code: f6 fe ff ff e8 4e 23 f5 c8 48 89 e6 4c 89 ff e8 d3 56 fa c8 45 85 ed 0f 85 16 ff ff ff 89 ee 48 c7 c7 78 
0e 18 c0 e8 9c 20 f5 c8 <0f> ff e9 01 ff ff ff 0f 1f 44 00 00 66 66 66 66 90 8b b7 18 01 
[   15.429101] ---[ end trace 23d115f7d4a179fb ]---
[   25.567166] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   35.807197] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:plane A] flip_done timed out
[   35.908149] ------------[ cut here ]------------
[   35.908197] vblank wait timed out on crtc 0
[   35.908260] WARNING: CPU: 0 PID: 103 at drivers/gpu/drm/drm_vblank.c:1071 drm_wait_one_vblank+0x1a4/0x1b0 [drm]
[   35.908300] Modules linked in: i915 firewire_ohci ata_generic firewire_core pata_acpi crc_itu_t i2c_algo_bit drm_kms_helper
 hid_appleir sky2 drm video hid_apple
[   35.908391] CPU: 0 PID: 103 Comm: kworker/u4:4 Tainted: G        W        4.15.0-0.rc7.git2.1.fc28.x86_64 #1
[   35.908429] Hardware name: Apple Inc. MacBook4,1/Mac-F22788A9, BIOS     MB41.88Z.00C1.B00.0802091535 02/09/08
[   35.908471] Workqueue: events_unbound async_run_entry_fn
[   35.908507] RIP: 0010:drm_wait_one_vblank+0x1a4/0x1b0 [drm]
[   35.908532] RSP: 0018:ffffbc3d40c8f920 EFLAGS: 00010282
[   35.908557] RAX: 0000000000000000 RBX: ffff9c4033240000 RCX: 0000000000000006
[   35.908586] RDX: 0000000000000007 RSI: ffff9c403490c000 RDI: ffff9c403b3d6c00
[   35.908616] RBP: 0000000000000000 R08: 0000000000000001 R09: 0000000000000000
[   35.908645] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000000
[   35.908674] R13: 0000000000000000 R14: 0000000002000001 R15: ffff9c4033df1808
[   35.908704] FS:  0000000000000000(0000) GS:ffff9c403b200000(0000) knlGS:0000000000000000
[   35.908738] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[   35.908762] CR2: 00007f4fcf331000 CR3: 000000011b412000 CR4: 00000000000006f0
[   35.908792] Call Trace:
[   35.908809]  ? finish_wait+0x80/0x80
[   35.908885]  intel_pre_plane_update+0xee/0x150 [i915]
[   35.908956]  intel_atomic_commit_tail+0xd5/0xc70 [i915]
[   35.908983]  ? complete+0x18/0x50
[   35.909051]  intel_atomic_commit+0x299/0x2d0 [i915]
[   35.909084]  drm_atomic_helper_commit_duplicated_state+0xd7/0x100 [drm_kms_helper]
[   35.909102]  intel_release_load_detect_pipe+0x4b/0x90 [i915]
[   35.909102]  intel_tv_detect+0x36a/0x4c0 [i915]
[   35.909102]  ? drm_helper_probe_single_connector_modes+0xde/0x6e0 [drm_kms_helper]
[   35.909102]  drm_helper_probe_single_connector_modes+0xde/0x6e0 [drm_kms_helper]
[   35.909102]  drm_setup_crtcs+0x166/0xc50 [drm_kms_helper]
[   35.909102]  __drm_fb_helper_initial_config_and_unlock+0x39/0x480 [drm_kms_helper]
[   35.909102]  intel_fbdev_initial_config+0x14/0x30 [i915]
[   35.909102]  async_run_entry_fn+0x33/0x160
[   35.909102]  process_one_work+0x243/0x6b0
[   35.909102]  worker_thread+0x3a/0x390
[   35.909102]  ? process_one_work+0x6b0/0x6b0
[   35.909102]  kthread+0x11f/0x140
[   35.909102]  ? kthread_create_worker_on_cpu+0x70/0x70
[   35.909102]  ret_from_fork+0x24/0x30
[   35.909102] Code: f6 fe ff ff e8 4e 23 f5 c8 48 89 e6 4c 89 ff e8 d3 56 fa c8 45 85 ed 0f 85 16 ff ff ff 89 ee 48 c7 c7 78 
0e 18 c0 e8 9c 20 f5 c8 <0f> ff e9 01 ff ff ff 0f 1f 44 00 00 66 66 66 66 90 8b b7 18 01 
[   35.909102] ---[ end trace 23d115f7d4a179fc ]---
[   35.920574] fbcon: inteldrmfb (fb0) is primary device
[   36.470630] Console: switching to colour frame buffer device 160x50
[   36.490072] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[   46.559215] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out

Comment 1 Filipe Rosset 2018-01-15 02:20:25 UTC
reproducible with kernel 4.15, 4.14, 4.8.6

not reproducible with kernel 4.1.12 (for while I'm using this one from fc22)

Comment 2 Filipe Rosset 2018-01-15 02:50:01 UTC
4.6.7 works too

Comment 3 Filipe Rosset 2018-01-15 02:50:18 UTC
4.6.7 works too

Comment 4 Filipe Rosset 2018-01-16 02:44:09 UTC
4.2.3 works fine, 4.6.7 works with erros/slowness

Comment 5 Filipe Rosset 2018-01-16 23:04:40 UTC
Created attachment 1382187 [details]
dmesg with kernel 4.15.0-0.rc8.git0.1.fc28.x86_64

dmesg with kernel 4.15.0-0.rc8.git0.1.fc28.x86_64

Comment 6 malkovjohnny 2018-01-18 10:39:22 UTC
It's old bug, looks some one broke driver since 4.9 kernel. Look here ->

https://bugs.freedesktop.org/show_bug.cgi?id=93782

Comment 7 Filipe Rosset 2018-01-18 23:12:08 UTC
(In reply to malkovjohnny from comment #6)
> It's old bug, looks some one broke driver since 4.9 kernel. Look here ->
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=93782

great, thanks, now I can work-around with kernel parameter "video=SVIDEO-1:d"

I doubt Intel will fix this issue soon, this machine will be 10 years old next month, still running working.


Note You need to log in before you can comment on or make changes to this bug.