Bug 1534333 - Missing dependency for mypy on psutil
Summary: Missing dependency for mypy on psutil
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python3-mypy
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1537870 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-15 03:51 UTC by wibrown@redhat.com
Modified: 2018-04-11 07:34 UTC (History)
6 users (show)

Fixed In Version: python3-mypy-0.560-2.fc26 python3-mypy-0.560-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-31 18:05:49 UTC


Attachments (Terms of Use)

Description wibrown@redhat.com 2018-01-15 03:51:39 UTC
Description of problem:
dnf install python3-mypy

Error received:

pkg_resources.DistributionNotFound: The 'psutil<5.5.0,>=5.4.0' distribution was not found and is required by mypy

rpm -qa| grep -i psutil

Not installed,

dnf install python3-psutil



How reproducible:
Always

Steps to Reproduce:
1. Install mypy
2.
3.

Actual results:
Missing python3-psutil dependency

Expected results:
python3-psutil would be installed as a requirement

Additional info:
Consider adding "Requires: python3-psutil" to the specfile for mypy.

Comment 1 Tomas Krizek 2018-01-16 12:33:01 UTC
The required python3-psutil version is not currently available in the Fedora repositories. Workaround is to install it with pip3.

Comment 2 Fedora Update System 2018-01-22 17:15:45 UTC
python-psutil-5.4.3-2.fc27 python3-mypy-0.560-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-84e90236f3

Comment 3 Fedora Update System 2018-01-22 17:15:58 UTC
python-psutil-5.4.3-2.fc26 python3-mypy-0.560-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-05b6ac0e4e

Comment 4 Fedora Update System 2018-01-23 22:50:35 UTC
python-psutil-5.4.3-2.fc26, python3-mypy-0.560-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-05b6ac0e4e

Comment 5 Fedora Update System 2018-01-23 23:42:24 UTC
python-psutil-5.4.3-2.fc27, python3-mypy-0.560-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-84e90236f3

Comment 6 Gwyn Ciesla 2018-01-24 12:09:16 UTC
*** Bug 1537870 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2018-01-31 18:05:49 UTC
python-psutil-5.4.3-2.fc26, python3-mypy-0.560-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-01-31 21:58:28 UTC
python-psutil-5.4.3-2.fc27, python3-mypy-0.560-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.