Bug 1534371 - Auto complete by oc suggests wrong resource
Summary: Auto complete by oc suggests wrong resource
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.9.0
Assignee: Maciej Szulik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-15 06:08 UTC by XiaochuanWang
Modified: 2019-02-26 16:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-26 16:09:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description XiaochuanWang 2018-01-15 06:08:01 UTC
Description of problem:
"oc get is<tab>" outputs "oc get ispersonalsubjectaccessreview"

Version-Release number of selected component (if applicable):
oc v3.9.0-0.19.0

How reproducible:
Always

Steps to Reproduce:
1.  Try following auto completion:
oc get is<tab> (or: oc delete/edit is<tab>)
oc get po<tab> # doesn't complete with "pod". It should complete. v3.7 does.
oc get d<tab> # doesn't complete with "dc". v3.7 also does not. It should complete short name like below "svc"
oc get sv<tab> # Can complete with "svc"

Actual results:
oc get ispersonalsubjectaccessreview

Expected results:
Should not suggest invalid resource.

Additional info:

Comment 2 Maciej Szulik 2019-02-26 16:09:36 UTC
It looks like the completions are not up-to-date. Feel free to reopen if this is still an issue.


Note You need to log in before you can comment on or make changes to this bug.