Bug 1534439
| Summary: | StreamingAPI - 'Transfer was paused by system' event/error is not informative enough | ||
|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Avihai <aefrat> |
| Component: | BLL.Storage | Assignee: | Daniel Erez <derez> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Avihai <aefrat> |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | 4.2.1 | CC: | aefrat, amureini, bugs, derez, ebenahar, lveyde, tnisan, ylavi |
| Target Milestone: | ovirt-4.2.2 | Flags: | rule-engine:
ovirt-4.2+
|
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | ovirt-engine-4.2.2.1 | Doc Type: | If docs needed, set a value |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2018-03-29 11:06:20 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Avihai
2018-01-15 09:22:45 UTC
Daniel - do we have a reasonable away of doing this for 4.2.z? We already output a warning/error message to the log on most scenarios that lead to PAUSED state.
E.g.:
"Could not get image ticket '{}' from vdsm"
"Transfer paused due to no updates in {} seconds. {}"
"Failed to renew transfer ticket for {}"
* Avihai - which flows have you encountered that didn't include any kind of useful error message?
(In reply to Daniel Erez from comment #2) > We already output a warning/error message to the log on most scenarios that > lead to PAUSED state. > E.g.: > "Could not get image ticket '{}' from vdsm" > "Transfer paused due to no updates in {} seconds. {}" > "Failed to renew transfer ticket for {}" > > * Avihai - which flows have you encountered that didn't include any kind of > useful error message? I will clarify: What I mean is to add the cause of the system pause to the event/audit log. This mean that instead of getting the generic event as i the example: " Updating image transfer 2e7a093e-27a0-4600-8be8-7fdf646c41d9 (image d0230b0e-2c6a-4f22-a673-301931d4d7e7) phase to Paused by System " You will get: "Updating image transfer 2e7a093e-27a0-4600-8be8-7fdf646c41d9 (image d0230b0e-2c6a-4f22-a673-301931d4d7e7) phase to Paused by System , caused by X " X will be a relevant message as you suggested above: "Could not get image ticket '{}' from vdsm" "Transfer paused due to no updates in {} seconds. {}" "Failed to renew transfer ticket for {}" Verified on 4.2.2.1-0.1 This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018. Since the problem described in this bug report should be resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |