Bug 1534564 - no log file for ceilometer polling on controllers
Summary: no log file for ceilometer polling on controllers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: beta
: 13.0 (Queens)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-15 13:37 UTC by Alex Krzos
Modified: 2018-06-27 13:42 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180304031146.6cd4184.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:42:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 542437 None MERGED Mount central agent log dir to access outside the container 2020-06-30 08:50:22 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:42:55 UTC

Description Alex Krzos 2018-01-15 13:37:35 UTC
Description of problem:
Ceilometer polling on the controllers does not seem to log to any file:

[root@overcloud-controller-0 ceilometer]# pwd
/var/log/containers/ceilometer
[root@overcloud-controller-0 ceilometer]# ls -la
total 1540
drwxr-xr-x.  2 42405 42405      66 Jan 14 21:42 .
drwxr-xr-x. 14 root  root      176 Jan 14 21:30 ..
-rw-r--r--.  1 42405 42405 1445315 Jan 15 13:36 agent-notification.log
-rw-r--r--.  1 42405 42405     359 Jan 14 21:42 ceilometer-upgrade.log
[root@overcloud-controller-0 ceilometer]# docker ps | grep ceilometer
c83be4838b7b        192.168.24.1:8787/rhosp12/openstack-ceilometer-notification-docker:12.0-20171201.1   "kolla_start"            15 hours ago        Up 15 hours (healthy)                       ceilometer_agent_notification
7f2183cff2a5        192.168.24.1:8787/rhosp12/openstack-ceilometer-central-docker:12.0-20171201.1        "kolla_start"            15 hours ago        Up 15 hours (healthy)                       ceilometer_agent_central
[root@overcloud-controller-0 ceilometer]# ps afx | grep ceilometer
 715077 pts/0    S+     0:00                          \_ grep --color=auto ceilometer
  12681 ?        Ss     7:14      |   \_ ceilometer-polling: master process [/usr/bin/ceilometer-polling --polling-namespaces central --logfile /var/log/ceilometer/central.log]
  22875 ?        Sl     1:13      |       \_ ceilometer-polling: AgentManager worker(0)
  13672 ?        Rs     7:11      |   \_ ceilometer-agent-notification: master process [/usr/bin/ceilometer-agent-notification --logfile /var/log/ceilometer/agent-notification.log]
  14348 ?        Sl     2:51      |       \_ ceilometer-agent-notification: NotificationService worker(0)
[root@overcloud-controller-0 ceilometer]# docker exec -it ceilometer_agent_central tailf /var/log/ceilometer/central.log
2018-01-15 13:34:30.149 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.system_stats.io.outgoing.blocks, no resources found this cycle
2018-01-15 13:34:30.149 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.system_stats.io.incoming.blocks, no resources found this cycle
2018-01-15 13:34:30.149 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.cpu.util, no resources found this cycle
2018-01-15 13:34:30.150 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.memory.used, no resources found this cycle
2018-01-15 13:34:30.150 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.memory.swap.total, no resources found this cycle
2018-01-15 13:34:30.150 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.network.ip.incoming.datagrams, no resources found this cycle
2018-01-15 13:34:30.150 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.memory.buffer, no resources found this cycle
2018-01-15 13:34:30.150 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.memory.total, no resources found this cycle
2018-01-15 13:34:30.150 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.memory.cached, no resources found this cycle
2018-01-15 13:34:30.151 128 INFO ceilometer.agent.manager [-] Skip pollster hardware.network.ip.outgoing.datagrams, no resources found this cycle


Version-Release number of selected component (if applicable):
OSP12 director / Pike
Build: 2018-01-04.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 errata-xmlrpc 2018-06-27 13:42:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.