Bug 1534718 - Message Preview Won't Scroll Properly on Space Character
Summary: Message Preview Won't Scroll Properly on Space Character
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kmail
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-15 19:32 UTC by Garry T. Williams
Modified: 2018-01-17 16:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-17 16:44:59 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 389120 None None None 2018-01-17 16:44:58 UTC

Description Garry T. Williams 2018-01-15 19:32:49 UTC
Description of problem:
The message preview window used to scroll a page at a time by entering a space character.  Once the bottom of the message was reached, another space charater caused the selection of the next unread message.

This behavior has been defined since forever.

Now, the only time the next unread message is selected is if the current message doesn't overflow the preview window.

Also, the scroll a page at a time is broken.  If the message is more than twice the vertical size of the preview window, the third space character cases a scroll backwards!


Version-Release number of selected component (if applicable):
kf5-kmailtransport-17.12.0-1.fc27.x86_64
kmail-17.12.0-1.fc27.x86_64
kf5-kmailtransport-akonadi-17.12.0-1.fc27.x86_64
kmail-libs-17.12.0-1.fc27.x86_64
kmail-account-wizard-17.12.0-1.fc27.x86_64


How reproducible: always

Comment 1 Garry T. Williams 2018-01-17 16:30:29 UTC
Upstream bug opened: https://bugs.kde.org/show_bug.cgi?id=389120

Comment 2 Rex Dieter 2018-01-17 16:44:59 UTC
Thanks, we'll continue tracking it there.


Note You need to log in before you can comment on or make changes to this bug.