Bug 15350 - Upgrade from 6.1 to 6.2 can leave system unbootable
Summary: Upgrade from 6.1 to 6.2 can leave system unbootable
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-04 05:48 UTC by gearon
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 00:41:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description gearon 2000-08-04 05:48:03 UTC
I had to help a friend (who works for Redhat Asia-Pacific) last night.
He is not a Linux expert and had upgraded his system from 6.1 to 6.2.
He upgraded everything on the system (including the kernel) but turned
off the option to re-run lilo.  (This was because he knew lilo controlled
the booting process, and the machine booted fine, so he thought it was
unnecessary).

The kernel 2.2.14 package removed the 2.2.12 kernel file from /boot,
even though lilo was not scheduled to be re-run.  This should not be
allowed.

If lilo is scheduled to be re-run then it is fine for the kernel upgrade to
delete the old kernel file.  If lilo is not to be re-run, then the old
kernel file cannot be deleted.  This can lead to the interesting problem
of a system working (as the boot loader points to a section of disk with
the old kernel) and suddenly failing one day once the old kernel blocks
get re-used.

Comment 1 Alan Cox 2002-12-15 00:41:17 UTC
Newer install/updates do this right



Note You need to log in before you can comment on or make changes to this bug.