Bug 1535004 - starting libreoffice without opening some document lets loop soffice.bin
Summary: starting libreoffice without opening some document lets loop soffice.bin
Keywords:
Status: CLOSED DUPLICATE of bug 1534149
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-16 12:59 UTC by Joachim Backes
Modified: 2018-01-16 17:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-16 17:21:39 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Joachim Backes 2018-01-16 12:59:07 UTC
Description of problem:
If open libreoffice, then soffice.bin eats one CPU

Version-Release number of selected component (if applicable):
libreoffice-5.4.4.2-3.fc27.x86_64

https://www-user.rhrk.uni-kl.de/~backes/

How reproducible:
always

Steps to Reproduce:
1.start libreoffice
2.
3.

Actual results:
une CPU is bysy with soffice.bin

Expected results:


Additional info:

1. Running ps:

0 R backes    4383  4368 99  80   0 - 412655 -     13:50 tty2     00:03:05 /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5


2. Running strace:

loops with the following output:

...

poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18, events=POLLIN}], 3, 4293) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18, events=POLLIN}], 3, 4293) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18, events=POLLIN}], 3, 4292) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18, events=POLLIN}], 3, 4292) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18, events=POLLIN}], 3, 4292) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18, events=POLLIN}], 3, 4291) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18, events=POLLIN}], 3, 4291) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18, events=POLLIN}], 3, 4291^C) = 1 ([{fd=9, revents=POLLIN}])


strace: Process 4383 detached
...

3. Occurs with previous versions of  LO too, for example with ibreoffice-5.4.4.2-1

Comment 1 Caolan McNamara 2018-01-16 17:21:39 UTC
the testing version of glib2 I imagine

*** This bug has been marked as a duplicate of bug 1534149 ***


Note You need to log in before you can comment on or make changes to this bug.