Bug 1535170 - OSP10->OSP13 FFU upgrade: openstack overcloud config download fails with: Deployment NetworkDeployment with group:os-apply-config not supported with config-download
Summary: OSP10->OSP13 FFU upgrade: openstack overcloud config download fails with: Dep...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Ryan Brady
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-16 18:47 UTC by Marius Cornea
Modified: 2018-06-27 13:42 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-common-8.4.1-0.20180214162358.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:42:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1748976 None None None 2018-02-12 19:53:48 UTC
OpenStack gerrit 543976 'None' 'MERGED' 'Deprecate group:os-apply-config with config-download' 2019-12-09 15:16:18 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:42:55 UTC

Description Marius Cornea 2018-01-16 18:47:04 UTC
Description of problem:

OSP10 -> OSP13 FFU upgrade: openstack overcloud config download fails with: Deployment NetworkDeployment with group:os-apply-config not supported with config-download

Steps to reproduce:

1. Deploy OSP10 undercloud + overcloud
2. Upgrade undercloud to OSP11
3. Upgrade undercloud to OSP12
4. Upgrade undercloud to OSP13
5. Update stack outputs:
openstack overcloud deploy \
--disable-validations \
--templates /usr/share/openstack-tripleo-heat-templates \
-e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
--control-scale 1 \
--control-flavor controller \
--compute-scale 1 \
--compute-flavor compute \
-e /home/stack/virt/config_lvm.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/hostnames.yml \
-e /home/stack/virt/debug.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker-ha.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/fast-forward-upgrade.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/noop-deploy-steps.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/config-download-environment.yaml \
-e /home/stack/docker_registry.yaml \

6. (undercloud) [stack@undercloud-0 ~]$ openstack overcloud config download

Deployment NetworkDeployment with group:os-apply-config not supported with config-download.

The nic templates in use on the overcloud do contain group: os-apply-config properties which were supported during OSP10 deployment. Here is the nic template for the controller role:

http://paste.openstack.org/show/645040/

config download works fine if before updating the stack outputs the nic templates are adjusted to use group: script. I think we need to provide a migration path(some script?) from old nic templates to the new required format because having to manually edit the nic templates is error prone and provides a terrible user experience.

Comment 2 Marius Cornea 2018-01-17 16:14:46 UTC
Note: the manual change of nic templates is very sensitive and error prone. I've just ended with the entire controller network connectivity getting disrupted because I misconfigured one line in the nic template.

Comment 15 errata-xmlrpc 2018-06-27 13:42:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.