Bug 1535206 - Upgrade from OCP 3.7.9 to 3.7.14 breaks service catalog etcd entries
Summary: Upgrade from OCP 3.7.9 to 3.7.14 breaks service catalog etcd entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.7.z
Assignee: Jeff Peeler
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-16 20:19 UTC by Greg Rodriguez II
Modified: 2018-04-05 09:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
3.7 upgrades were incorrectly using an old default etcd port value of 4001 and was modified to the proper number of 2379.
Clone Of:
Environment:
Last Closed: 2018-04-05 09:35:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:35:55 UTC

Description Greg Rodriguez II 2018-01-16 20:19:02 UTC
Description of problem:
After upgrading OCP from 3.7.9 to 3.7.14 service catalog stops working.  Found issue below: 
    
     https://github.com/openshift/origin/issues/17951


Version-Release number of selected component (if applicable):
3.7.14

How reproducible:
Have not been able to produce in-house.

Steps to Reproduce:
1. N/A
2. N/A
3. N/A

Comment 2 Jeff Peeler 2018-01-18 18:57:01 UTC
I updated the issue on github to point to the already committed fix. If I'm correct about the issue having already been taken care of, the OCP upgrade that will fix the problem will be in 3.7.24.

Comment 3 Jeff Peeler 2018-01-19 18:57:26 UTC
(This was fixed for bug 1523298.)

Comment 5 Jian Zhang 2018-01-25 05:35:23 UTC
I have already tested this issue with the newer 3.7.24-1.git.0.18a2c6a.el7.noarch, it works well! So, it looks good to me.

Comment 10 errata-xmlrpc 2018-04-05 09:35:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.