Bug 1535300 - [REF] use openshift-logging as the default logging project
Summary: [REF] use openshift-logging as the default logging project
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks: 1588290
TreeView+ depends on / blocked
 
Reported: 2018-01-17 04:45 UTC by Anping Li
Modified: 2018-07-30 19:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Default the project using for the EFK stack to 'openshift-logging' Reason: This fits the pattern used by other infrastructure application and allows the EFK stack to participate with other services that assume infrastructure is deployed to namespaces with a known pattern (e.g. openshift-) Result: Existing deployments of logging will continue to live in the 'logging' namespace while new deployments will be deployed to 'openshift-logging'
Clone Of:
: 1588290 (view as bug list)
Environment:
Last Closed: 2018-07-30 19:09:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:34 UTC
Github openshift openshift-ansible pull 7394 None None None 2018-03-05 22:08:17 UTC
Github openshift openshift-ansible pull 7810 None None None 2018-04-05 14:27:23 UTC
Github openshift origin-aggregated-logging pull 1006 None None None 2018-03-07 21:25:53 UTC
Github openshift origin-aggregated-logging pull 1033 None None None 2018-03-22 02:36:26 UTC

Description Anping Li 2018-01-17 04:45:10 UTC
Description of problem:

The prefix kube- and openshift- are perserved for internal use case. to avoid name conflict, it is better to use  the preserved prefix as default logging project. 



Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. A customer user create a project named logging
2. The openshift admin deploy logging with default values


Actual results:
The logging are deployed to customer's project logging.

Expected results:

The logging are deployed to  preserved project name openshift-logging.


Additional info:

Comment 4 openshift-github-bot 2018-03-21 22:50:45 UTC
Commit pushed to master at https://github.com/openshift/origin-aggregated-logging

https://github.com/openshift/origin-aggregated-logging/commit/06925e7159824df0c0c7fe63e6aeabb9aec2a166
bug 1535300. modify the default namespace for logging

Comment 6 openshift-github-bot 2018-04-13 04:39:07 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/a9bb7dab6921caadab40676fe13da9b797ce80c7
bug 1535300. Default logging namespace to openshift-logging

Comment 7 Junqi Zhao 2018-05-14 05:34:13 UTC
logging default project is openshift-logging now.

# rpm -qa | grep openshift-ansible
openshift-ansible-3.10.0-0.38.0.git.7.848b045.el7.noarch
openshift-ansible-docs-3.10.0-0.38.0.git.7.848b045.el7.noarch
openshift-ansible-roles-3.10.0-0.38.0.git.7.848b045.el7.noarch
openshift-ansible-playbooks-3.10.0-0.38.0.git.7.848b045.el7.noarch

Comment 8 openshift-github-bot 2018-06-20 15:06:00 UTC
Commit pushed to master at https://github.com/openshift/origin-aggregated-logging

https://github.com/openshift/origin-aggregated-logging/commit/33f677c2761497efe14593361c495c0cce354c53
bug 1535300. modify the default namespace for logging

(cherry picked from commit 06925e7159824df0c0c7fe63e6aeabb9aec2a166)

Comment 10 errata-xmlrpc 2018-07-30 19:09:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.