Bug 1535445 - Update tripleo-ui dependencies
Summary: Update tripleo-ui dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-17 12:09 UTC by Beth White
Modified: 2018-06-27 13:43 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-ui-8.3.1-0.20180303225336.57e3d96.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:42:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1743722 None None None 2018-01-24 14:49:52 UTC
OpenStack gerrit 534305 None master: ABANDONED tripleo-ui: Upgrade prettier (I115e537737a2a66dc788fcc53c5d1c90e19c2e28) 2018-03-21 13:45:47 UTC
OpenStack gerrit 534759 None master: MERGED tripleo-ui: Update dependencies (I1767978329f4e0eb6f1731694762b505147576cf) 2018-03-21 13:45:40 UTC
OpenStack gerrit 534761 None master: MERGED tripleo-ui: Fix bugs caused by dependencies update (I2d9ffb9207574e1c8959b7372de1a273d7e31274) 2018-03-21 13:45:33 UTC
OpenStack gerrit 534954 None master: MERGED tripleo-ui: Resolve CI issues (I6b7d1116f522a6a1dd5e8455e85f4db958424e7c) 2018-03-21 13:45:27 UTC
OpenStack gerrit 535323 None master: MERGED tripleo-ui: Update dependencies part II (I0a4668bd49c499c1542893995497e529c8e01535) 2018-03-21 13:45:20 UTC
OpenStack gerrit 535324 None master: MERGED tripleo-ui: Fix EnvironmentConfiguration dialog (Ia056621a847b56913b1dfff57f6e8237f62bd8d7) 2018-03-21 13:45:13 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:43:05 UTC

Description Beth White 2018-01-17 12:09:33 UTC
We need to keep tripleo-ui dependencies up to date. The goal is to release OSP13 with React 16 so potential backports are not complicated.

Comment 5 Udi 2018-04-04 11:22:29 UTC
How do I test what the dependencies are? I don't see React16 in the RPM dependencies:

rpm -qR openstack-tripleo-ui-8.3.1-2.el7ost.noarch
config(openstack-tripleo-ui) = 8.3.1-2.el7ost
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

Comment 6 Florian Fuchs 2018-06-19 13:07:51 UTC
(In reply to Udi from comment #5)
> How do I test what the dependencies are? I don't see React16 in the RPM
> dependencies:
> 
> rpm -qR openstack-tripleo-ui-8.3.1-2.el7ost.noarch
> config(openstack-tripleo-ui) = 8.3.1-2.el7ost
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(FileDigests) <= 4.6.0-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(PayloadIsXz) <= 5.2-1

React 16 isn't installed as an rpm dependency but as part of the RDO build process so it can't be listed with repm/yum commands. 

I am not sure if this sufficient for testing, but React 16 was introduced in tripleo-ui 8.3.0. So openstack-tripleo-ui-8.3.1 is built with 16 as well.

Comment 7 Julie Pichon 2018-06-19 14:29:17 UTC
Opening the source RPM (openstack-tripleo-ui-8.3.1-3.el7ost.src.rpm) and looking in package.json I can confirm it was built with React 16:

$ grep \"react\" package.json
    "react": "^16.2.0",

If someone can confirm that the UI works just fine with openstack-tripleo-ui-8.3.1-3.el7ost installed that seems sufficient to me for a basic SanityCheck.

Comment 8 Dan Trainor 2018-06-19 16:59:56 UTC
Confirmed, and UI appears to work just fine:

(undercloud) [stack@rdo-ci-fx2-04-s8 openstack-tripleo-ui]$ rpm2cpio openstack-tripleo-ui-8.3.1-3.el7ost.src.rpm | cpio -idmv
0001-Downstream-brand-for-Red-Hat-OpenStack-Director-13.patch
0002-Pass-currentPlanName-when-fetching-available-roles.patch
openstack-tripleo-ui.spec
tripleo-ui-8.3.1.tar.gz
tripleo-ui.conf
1621 blocks
(undercloud) [stack@rdo-ci-fx2-04-s8 openstack-tripleo-ui]$ tar -xf tripleo-ui-8.3.1.tar.gz 
(undercloud) [stack@rdo-ci-fx2-04-s8 openstack-tripleo-ui]$ grep grep \"react\" package/package.json 
grep: "react": No such file or directory
(undercloud) [stack@rdo-ci-fx2-04-s8 openstack-tripleo-ui]$  grep \"react\" package/package.json 
    "react": "^16.2.0",
(undercloud) [stack@rdo-ci-fx2-04-s8 openstack-tripleo-ui]$

Comment 10 errata-xmlrpc 2018-06-27 13:42:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.