Bug 1535475 - OSP10 -> OSP13 FFU upgrade: upgrade_steps_playbook.yaml: pre upgrade validations are placed at the end of the controller upgrade playbook
Summary: OSP10 -> OSP13 FFU upgrade: upgrade_steps_playbook.yaml: pre upgrade validati...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Ryan Brady
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-17 13:23 UTC by Marius Cornea
Modified: 2018-06-27 13:43 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-common-8.4.1-0.20180224032817.d51ed49.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:42:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1743777 None None None 2018-01-17 13:23:20 UTC
OpenStack gerrit 529369 None None None 2018-01-24 13:19:06 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:43:05 UTC

Description Marius Cornea 2018-01-17 13:23:20 UTC
Description of problem:
OSP10 -> OSP13 FFU upgrade: upgrade_steps_playbook.yaml: pre upgrade validations are placed at the end of the controller upgrade playbook.

I am not sure that in case of FFU we need those validations as the services shouldn't be running at this point. Attaching the controller upgrade playbook where you can see the validations are placed at the end of the playbook: http://paste.openstack.org/show/646509/

Comment 2 Marios Andreou 2018-01-24 13:19:06 UTC
This has same root cause as BZ 1535442 and should also be fixed by https://review.openstack.org/#/c/529369/ which addresses the task ordering - marking triaged

Comment 12 errata-xmlrpc 2018-06-27 13:42:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.