Bug 1535495 - Add option -h and --help to gluster cli
Summary: Add option -h and --help to gluster cli
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-17 14:12 UTC by M. Scherer
Modified: 2019-03-25 16:30 UTC (History)
2 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:30:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21698 0 None Merged cli: \"usage()\" and \"--help\" for gluster cli 2018-12-04 09:29:04 UTC

Description M. Scherer 2018-01-17 14:12:58 UTC
Description of problem:

So, when running a tool for the first time, I usually try to use --help or -h to see what I need to do with it.

Not for gluster:


[root@proxy01 ~]# gluster -h
unrecognized word: -h (position 0)
[root@proxy01 ~]# gluster --help
unrecognized option --help
[root@proxy01 ~]# gluster help
 peer help                - display help for peer commands
 volume help              - display help for volume commands
 volume bitrot help       - display help for volume bitrot commands
 volume quota help        - display help for volume quota commands
 volume tier help         - display help for volume tier commands
 snapshot help            - display help for snapshot commands
 global help              - list global commands

Could -h and --help be alias for help ?


Version-Release number of selected component (if applicable):

glusterfs-3.12.5-1.fc27.x86_64

How reproducible:

each time

Steps to Reproduce:
1. gluster -h


Actual results:

unrecognized word: -h (position 0)


Expected results:

 peer help                - display help for peer commands
 volume help              - display help for volume commands
 volume bitrot help       - display help for volume bitrot commands
 volume quota help        - display help for volume quota commands
 volume tier help         - display help for volume tier commands
 snapshot help            - display help for snapshot commands
 global help              - list global commands


Additional info:

none, but thanks for asking.

Comment 1 Worker Ant 2018-11-21 10:53:41 UTC
REVIEW: https://review.gluster.org/21698 (cli: \"usage()\" and \"--help\" for gluster cli) posted (#1) for review on master by Harpreet Kaur Lalwani

Comment 2 Worker Ant 2018-12-04 09:29:02 UTC
REVIEW: https://review.gluster.org/21698 (cli: \"usage()\" and \"--help\" for gluster cli) posted (#3) for review on master by Amar Tumballi

Comment 4 Shyamsundar 2019-03-25 16:30:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.