Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1535521

Summary: OVA import failed when importing RHV OVA with big disk size.
Product: [oVirt] ovirt-engine Reporter: Nisim Simsolo <nsimsolo>
Component: BLL.VirtAssignee: Arik <ahadas>
Status: CLOSED CURRENTRELEASE QA Contact: Nisim Simsolo <nsimsolo>
Severity: high Docs Contact:
Priority: high    
Version: 4.2.1.1CC: bugs, michal.skrivanek, nsimsolo, t0x1c666
Target Milestone: ovirt-4.2.2Flags: rule-engine: ovirt-4.2+
rule-engine: blocker+
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-29 11:05:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1049604, 1449869    
Attachments:
Description Flags
engine.log
none
vdsm.log
none
ova import log
none
ova ansible log none

Description Nisim Simsolo 2018-01-17 14:53:22 UTC
Description of problem:
Importing of RHV origin OVA with big disk size (the size of the concurrent file is 21G), failed with the next ova.log:

UnicodeDecodeError: 'ascii' codec can't decode byte 0x80 in position 0: ordinal not in range(128)

and engine.log:

2018-01-17 16:41:29,243+02 ERROR [org.ovirt.engine.core.bll.exportimport.ExtractOvaCommand] (EE-ManagedThreadFactory-engine-Thread-36600) [6ce62cc7] Failed to extract OVA. Please check logs for more details: /var/log/ovirt-engine/ova/ovirt-import-ova-ansible-20180117164126-10.35.5.0-6ce62cc7.log
2018-01-17 16:41:29,247+02 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.TeardownImageVDSCommand] (EE-ManagedThreadFactory-engine-Thread-36600) [6ce62cc7] START, TeardownImageVDSCommand(HostName = intel_vGPU, ImageActionsVDSCommandParameters:{hostId='79786002-39a9-413f-b8a6-ab7752d77b2a'}), log id: 224701d0
2018-01-17 16:41:29,252+02 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.TeardownImageVDSCommand] (EE-ManagedThreadFactory-engine-Thread-36600) [6ce62cc7] FINISH, TeardownImageVDSCommand, return: StatusReturn:{status='Status [code=0, message=Done]'}, log id: 224701d0
2018-01-17 16:41:29,255+02 ERROR [org.ovirt.engine.core.bll.exportimport.ImportVmFromOvaCommand] (EE-ManagedThreadFactory-engine-Thread-36600) [6ce62cc7] Failed to extract OVA file

Importing smaller OVA file (4.2G) succeed and imported VM is running properly

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.1.1-0.1.el7
libvirt-client-3.2.0-14.el7_4.7.x86_64
vdsm-4.20.13-1.el7ev.x86_64
qemu-kvm-rhev-2.9.0-16.el7_4.13.x86_64

How reproducible:
Depends on disk size, I also tried to import OVA of 9.1G and it failed for the same reason.

Steps to Reproduce:
1. Export RHV VM as OVA.
2. Import OVA file.
3.

Actual results:
Import failed

Expected results:
Import should not fail.

Additional info:
ova.log, engine.log and vdsm.log attached

Comment 1 Nisim Simsolo 2018-01-17 15:45:30 UTC
Created attachment 1382527 [details]
engine.log

Comment 2 Nisim Simsolo 2018-01-17 15:46:45 UTC
Created attachment 1382529 [details]
vdsm.log

Comment 3 Nisim Simsolo 2018-01-17 15:47:19 UTC
Created attachment 1382530 [details]
ova import log

Comment 4 Nisim Simsolo 2018-01-17 15:48:02 UTC
Created attachment 1382531 [details]
ova ansible log

Comment 5 Nisim Simsolo 2018-02-18 15:24:32 UTC
Verification build:
rhvm-4.2.2-0.1.el7
vdsm-4.20.18-1.el7ev.x86_64
qemu-kvm-rhev-2.9.0-16.el7_4.14.x86_64
libvirt-client-3.2.0-14.el7_4.9.x86_64
sanlock-3.5.0-1.el7.x86_64

Verification scenario:
1. Import OVA of 22GB file size.
2. Verify OVA imported and verify VM configuration is correct (mem size, disk size, MAC address etc.)
3. Run VM and verify VM is running properly.

Comment 6 Sandro Bonazzola 2018-03-29 11:05:56 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.