Bug 1535620 - tempest scenario 'test_network_v6' tests fail because router address sometimes is incorrectly deallocated
Summary: tempest scenario 'test_network_v6' tests fail because router address sometime...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z7
: 10.0 (Newton)
Assignee: Ihar Hrachyshka
QA Contact: Arie Bregman
URL:
Whiteboard:
Depends On: 1486324 1535624 1535628
Blocks: 1497514 1535619 1535623
TreeView+ depends on / blocked
 
Reported: 2018-01-17 18:25 UTC by Ihar Hrachyshka
Modified: 2018-02-27 16:42 UTC (History)
10 users (show)

Fixed In Version: openstack-neutron-9.4.1-12.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1486324
Environment:
Last Closed: 2018-02-27 16:42:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1743658 None None None 2018-01-17 18:25:20 UTC
OpenStack gerrit 518107 None None None 2018-01-17 18:25:20 UTC
OpenStack gerrit 518108 None None None 2018-01-17 18:25:20 UTC
OpenStack gerrit 534456 None None None 2018-01-17 18:25:20 UTC
Red Hat Product Errata RHBA-2018:0357 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2018-02-27 21:38:41 UTC

Comment 6 Ihar Hrachyshka 2018-02-19 21:42:01 UTC
The problem with saying that the test still fails in some job is that the test failure is really generic (what it indicates is that data path is broken at some point, but it can be millions of reasons, from ovs bridges to l3 router issues to issues on tempest node). With that, I don't think we can meaningfully track them all with a single bug. The bug I was pursuing before was fixed. Whatever will come up with new failure reports is probably some different bug.

I guess we could change this bug report title to reflect the actual root cause, in which case it will match the fact that this bug is not overarching for all possible failures of the test class, today or in the future.

Comment 9 errata-xmlrpc 2018-02-27 16:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0357


Note You need to log in before you can comment on or make changes to this bug.