Bug 1535658 - [3.7] New auto egress IPs will fail after restarting node service
Summary: [3.7] New auto egress IPs will fail after restarting node service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.z
Assignee: Dan Winship
QA Contact: Meng Bo
URL:
Whiteboard:
: 1547008 (view as bug list)
Depends On: 1533153 1535659
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-17 20:29 UTC by Ben Bennett
Modified: 2018-07-23 08:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Certain initialization code was only run when doing a full SDN setup, and not when OpenShift was restarted and found the SDN was already up and running. Consequence: If the atomic-openshift-node service was restarted, that node would be unable to create new per-project static egress IPs (HostSubnet.EgressIPs). Fix: The egress IP initialization code is now run in all circumstances. Result: Per-project static egress IPs work correctly, even after a node restart.
Clone Of: 1533153
Environment:
Last Closed: 2018-04-05 09:35:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ose pull 1042 None None None 2018-02-05 18:54:44 UTC
Origin (Github) 18049 None None None 2018-01-17 20:29:38 UTC
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:35:55 UTC

Description Ben Bennett 2018-01-17 20:29:38 UTC
+++ This bug was initially created as a clone of Bug #1533153 +++

Description of problem:
After a "simple" restart of a node (such that it doesn't need to re-setup the SDN), newly-created egress IPs won't work correctly

Steps to Reproduce:
1. Start a cluster
2. On one of the nodes, "systemctl restart atomic-openshift-node"
3. Add an auto-egress-IP to that node

Actual results:
Newly-added egress IP doesn't work, and there's an ovs-related error in the journal for that node

Expected results:
Works

--- Additional comment from Dan Winship on 2018-01-10 10:36:48 EST ---

https://github.com/openshift/origin/pull/18049 fixes this for master. I'll update when there's a backport to 3.7.

Comment 1 Dan Winship 2018-01-30 16:31:53 UTC
fyi I was waiting for https://github.com/openshift/origin/pull/18121 to merge so I could backport them together rather than having to two separate bugs

Comment 2 Dan Winship 2018-01-31 14:39:01 UTC
https://github.com/openshift/ose/pull/1042

Comment 4 Meng Bo 2018-02-14 09:21:58 UTC
Tested on OCP v3.7.29

The egress IP will work well after the node service restarted on egress node.
And the egress IP works well when the order of OPENSHIFT-MASQUERADE and KUBE-POSTROUING switched.

Comment 5 Dan Winship 2018-02-20 14:43:51 UTC
*** Bug 1547008 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2018-04-05 09:35:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.