Bug 1535766 - VIFs not always detached from ironic nodes after stack delete
Summary: VIFs not always detached from ironic nodes after stack delete
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 12.0 (Pike)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Julia Kreger
QA Contact: mlammon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-18 03:42 UTC by Anil Dhingra
Modified: 2018-06-27 13:43 UTC (History)
7 users (show)

Fixed In Version: openstack-ironic-10.1.2-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:42:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1743652 None None None 2018-01-22 14:34:16 UTC
OpenStack gerrit 562314 'None' 'MERGED' 'Remove vifs upon teardown' 2019-12-06 03:47:43 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:43:13 UTC

Description Anil Dhingra 2018-01-18 03:42:40 UTC
Description of problem:
Sometimes when a baremetal instance is terminated, some VIFs are not detached from the node. This can lead to the node becoming unusable, with subsequent attempts to provision it fail during VIF attachment due to there being insufficient free ironic ports to attach the VIF to.

Version-Release number of selected component (if applicable):


How reproducible:
after multiple attemt of stack create/delete to test multiple scenarios it faild with VIF attachment 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
instance should boot successfully

Additional info:

Looks similar to upstream bug https://bugs.launchpad.net/nova/+bug/1733861

Comment 2 Julia Kreger 2018-01-19 16:35:21 UTC
This seems related to https://bugs.launchpad.net/ironic/+bug/1743652 which has a patch in progress to update the upstream conductor behavor.

Comment 6 Bob Fournier 2018-03-27 13:33:15 UTC
Changing state on this as the fix in https://review.openstack.org/#/c/534441/ was reverted.  Upstream patch https://review.openstack.org/#/c/556748/ will probably be fix after backport.

Comment 10 Bob Fournier 2018-05-11 15:39:05 UTC
Per DFG discussion on 5/11 - this problem is being seen more often as the cause of failed deployments and as such we are considering it a blocker.

A patch has landed in stable/queens that will be backported.

Comment 12 mlammon 2018-05-22 20:05:23 UTC
Installed latest osp13  5.18.01  

We don't have same exact setup but make every effort to try and re-produce. 

In RHV env since it was available ... 3 controller, 1 compute deployment. 

1. delete deployment
2. check vif exist on nodes (openstack baremetal node vif list <uuid>)
reported bug showing this has been seen leftover from previous delete
3. re-deploy deployment
4. check vif exisit
5. delete deployment
6. check vif exist 

repeated above a two times ^^^

--
In another virtual environment (3 controller, 1 compute, 3 ceph nodes)

followed steps 1..7 above
repeated this procedure two times.

In total (4) attempts to reproduce the issue.  It appears now we can verify.
Please re-open or file new bz if seen again.

Comment 14 errata-xmlrpc 2018-06-27 13:42:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.