Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Version-Release number of selected component (if applicable):
subscription-manager-plugin-ostree-1.20.9-1.el7.x86_64
subscription-manager-initial-setup-addon-1.20.9-1.el7.x86_64
subscription-manager-rhsm-1.20.9-1.el7.x86_64
subscription-manager-migration-1.20.9-1.el7.x86_64
subscriber-performance-subscriber-1.0-4.noarch
subscription-manager-1.20.9-1.el7.x86_64
subscription-manager-plugin-container-1.20.9-1.el7.x86_64
subscription-manager-cockpit-1.20.8-1.el7.noarch
subscription-manager-debuginfo-1.20.8-1.el7.x86_64
subscription-manager-gui-1.20.9-1.el7.x86_64
subscription-manager-rhsm-certificates-1.20.9-1.el7.x86_64
subscription-manager-migration-data-2.0.37-1.el7.noarch
How reproducible:
Always
Steps to Reproduce:
1.Launch cockpit UI
2.click on "subscriptions"
3.click on "Register"
4.Choose "Custom URL"
5.Input the stage url "subscription.rhsm.redhat.com" or "subscription.rhsm.redhat.com:443/subscription"
6.provide username and password and click register
Actual results:
The dialog window is closed , but the "subscriptions" tab continued to show "Status: This system is currently not registered." when you try to register again , it says "This system is already registered" (logs details ,see additional info section)
Expected results:
1) user should be allowed to register using custom url
2) A water mark of the url format should be displayed in the text field of custom url ,so that user know the expected format
3) Need appropriate error message on cockpit when registration fails
Additional info:
/var/log/messages
Jan 18 06:19:16 hp-dl380pgen8-02-vm-7 rhsm-service: ERROR [subscription_manager.cache:238] Server unreachable, registered, but no cache exists.
Jan 18 06:19:16 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Jan 18 06:19:16 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Jan 18 06:19:18 hp-dl380pgen8-02-vm-7 dbus[622]: [system] Activating service name='com.redhat.SubscriptionManager' (using servicehelper)
Jan 18 06:19:18 hp-dl380pgen8-02-vm-7 dbus[622]: [system] Successfully activated service 'com.redhat.SubscriptionManager'
Jan 18 06:19:19 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Jan 18 06:19:19 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Jan 18 06:19:20 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Jan 18 06:19:20 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Jan 18 06:19:20 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [rhsm.connection:868] Connection built: host=subscription.rhsm.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
Jan 18 06:19:21 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [rhsm.connection:586] Response: status=401, requestUuid=8b508dc1-d375-4146-9577-e04ca185a6e4, request="GET /subscription/consumers/545f0403-4faf-49d4-a459-488e805ec4ec/compliance"
Jan 18 06:19:21 hp-dl380pgen8-02-vm-7 rhsm-service: ERROR [subscription_manager.cache:235] Invalid credentials.
Jan 18 06:19:21 hp-dl380pgen8-02-vm-7 rhsm-service: ERROR [subscription_manager.cache:238] Server unreachable, registered, but no cache exists.
Jan 18 06:19:21 hp-dl380pgen8-02-vm-7 rhsm-service: INFO [rhsm.connection:586] Response: status=401, requestUuid=b92fd917-35f4-4c2f-975b-4b4f11a31754, request="GET /subscription/consumers/545f0403-4faf-49d4-a459-488e805ec4ec"
Jan 18 06:19:21 hp-dl380pgen8-02-vm-7 rhsm-service: ERROR [subscription_manager.cache:235] Invalid credentials.
Jan 18 06:19:21 hp-dl380pgen8-02-vm-7 rhsm-service: ERROR [subscription_manager.cache:238] Server unreachable, registered, but no cache exists.
^C
[root@hp-dl380pgen8-02-vm-7 ~]# grep '\[server\]' -A15 /etc/rhsm/rhsm.conf
Seems like a part of the issue is that the UI is still usable while registration is happening. Let's block the UI until the registration completes and then verify if the issue remains.
Created attachment 1679044[details]
System is registered successfully using custom url
Verification:
[root@hpe-dl380pgen8-02-vm-4 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.9.21-1
subscription management rules: 5.37
subscription-manager: 1.24.32
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (subscription-manager bug fix update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2020:3866