Bug 1536023 - Cannot restore disk layout of software raid devices when some device is missing
Summary: Cannot restore disk layout of software raid devices when some device is missing
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear   
(Show other bugs)
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: David Jež
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-18 13:34 UTC by Renaud Métrich
Modified: 2018-10-30 11:44 UTC (History)
3 users (show)

Fixed In Version: rear-2.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 11:43:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3293 None None None 2018-10-30 11:44 UTC

Description Renaud Métrich 2018-01-18 13:34:59 UTC
Description of problem:

If a software raid device is in degraded state at the time of the "rear mkrescue" creation (e.g. a device has been removed from a RAID1 array), the disk layout restoration will fail with following error seen in the log:

mdadm --create /dev/md127 --force --metadata=1.2 --level=raid1 --raid-devices=2 --uuid=a0fc5637:fdf5dafa:a345e010:83293548 --name=boot /dev/sdb1
+++ echo Y
mdadm: You haven't given enough devices (real or missing) to create this array


This is indeed due to the missing device (/dev/mapper/mpatha1)


Version-Release number of selected component (if applicable):

rear-2.00-3.el7_4.x86_64


How reproducible:

ALWAYS


Steps to Reproduce:
1. Set up a software raid with 2 devices in RAID1
2. Remove one of the device (/dev/sda1)
3. Create rear rescue image
4. Try restoring the disk layout

Actual results:

initramfs's /var/lib/rear/layout/disklayout.conf will contain:

raid /dev/md127 metadata=1.2 level=raid1 raid-devices=2 uuid=a0fc5637:fdf5dafa:a345e010:83293548 name=boot devices=/dev/sdb1
...

leading to mdadm complaining and aborting.


Additional info:

Issue to be created in Upstream as well

Comment 4 Pavel Cahyna 2018-06-27 16:25:09 UTC
1536023 merged upstream in 2.4/643d778e6a39a869bd9e5962436285fbb44fa71c

Comment 9 errata-xmlrpc 2018-10-30 11:43:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3293


Note You need to log in before you can comment on or make changes to this bug.