Bug 1536075
| Summary: | Failed to run vm after snapshot-preview: unsupported configuration: Found duplicate drive address for disk with target name 'sdc' | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Evelina Shames <eshames> | ||||
| Component: | BLL.Storage | Assignee: | Tal Nisan <tnisan> | ||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Evelina Shames <eshames> | ||||
| Severity: | medium | Docs Contact: | |||||
| Priority: | high | ||||||
| Version: | 4.2.1 | CC: | amureini, bugs, ebenahar, tnisan, ylavi | ||||
| Target Milestone: | ovirt-4.2.2 | Flags: | rule-engine:
ovirt-4.2+
ylavi: exception+ |
||||
| Target Release: | 4.2.2.2 | ||||||
| Hardware: | Unspecified | ||||||
| OS: | Unspecified | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | ovirt-engine-4.2.2.2 | Doc Type: | If docs needed, set a value | ||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2018-04-18 12:26:19 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
Tal, This bug looks very similar to bug #1529460. Can you please take a look? (In reply to Raz Tamir from comment #1) > Tal, > > This bug looks very similar to bug #1529460. > Can you please take a look? Tentatively targetting to 4.2.2 like that one until Tal has a chance to examine this. (In reply to Allon Mureinik from comment #2) > (In reply to Raz Tamir from comment #1) > > Tal, > > > > This bug looks very similar to bug #1529460. > > Can you please take a look? > > Tentatively targetting to 4.2.2 like that one until Tal has a chance to > examine this. Tal, any news? Been trying to reproduce this bug along with bug 1545229 but couldn't, working with the QE team to see if they can still reproduce or a fix found his way in somehow and try to track what exactly it was (In reply to Tal Nisan from comment #4) > Been trying to reproduce this bug along with bug 1545229 but couldn't, > working with the QE team to see if they can still reproduce or a fix found > his way in somehow and try to track what exactly it was The bug is reproducible on my environment: Engine: evelina-engine-ovirt.scl.lab.tlv.redhat.com VM: vm0 Verified. ovirt-engine: 4.2.2.4 vdsm: vdsm-4.20.22 This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018. Since the problem described in this bug report should be resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |
Created attachment 1382927 [details] Logs Description of problem: VM with 4 nfs disks, create 3 live snapshots, power off the vm, delete disk snapshot of the middle snapshot and preview but the vm failed to start: VM is down with error. Exit message: unsupported configuration: Found duplicate drive address for disk with target name 'sdc' controller='0' bus='0' target='0' unit='3'. Version-Release number of selected component (if applicable): Engine: 4.2.1-0.2.el7 Vdsm: 4.20.9-1.el7ev libvirt: 3.2.0-14 How reproducible: Happened once. Steps to Reproduce: 1.VM with 4 nfs disks 2.create 3 live snapshots 3.power off the vm 4.delete disk snapshot of the middle snapshot 5.preview middle snapshot 6.start vm Actual results: VM is down with error. Exit message: unsupported configuration: Found duplicate drive address for disk with target name 'sdc' controller='0' bus='0' target='0' unit='3'. Expected results: VM is running Additional info: vdsm log: 2018-01-18 14:33:42,005+0200 ERROR (vm/66bd9997) [virt.vm] (vmId='66bd9997-7a71-46b7-afcf-f7838bc9d366') The vm start process failed (vm:911) Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 840, in _startUnderlyingVm self._run() File "/usr/lib/python2.7/site-packages/vdsm/virt/vm.py", line 2704, in _run dom = self._connection.defineXML(domxml) File "/usr/lib/python2.7/site-packages/vdsm/libvirtconnection.py", line 126, in wrapper ret = f(*args, **kwargs) File "/usr/lib/python2.7/site-packages/vdsm/utils.py", line 512, in wrapper return func(inst, *args, **kwargs) File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3585, in defineXML if ret is None:raise libvirtError('virDomainDefineXML() failed', conn=self) libvirtError: unsupported configuration: Found duplicate drive address for disk with target name 'sdc' controller='0' bus='0' target='0' unit='3' 2018-01-18 14:33:42,006+0200 INFO (vm/66bd9997) [virt.vm] (vmId='66bd9997-7a71-46b7-afcf-f7838bc9d366') Changed state to Down: unsupported configuration: Found duplicate drive address for disk with target name 'sdc' controller='0' bus='0' target='0' unit='3' (code=1) (vm:1630) engine log: 2018-01-18 14:33:46,372+02 INFO [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (ForkJoinPool-1-worker-5) [] START, DestroyVDSCommand(HostName = h2, DestroyVmVDSCommandParameters:{hostId='b19c0601 -b762-4345-a275-aba2e04bd60c', vmId='66bd9997-7a71-46b7-afcf-f7838bc9d366', secondsToWait='0', gracefully='false', reason='', ignoreNoVm='true'}), log id: 1311bdbe 2018-01-18 14:33:47,449+02 INFO [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (ForkJoinPool-1-worker-5) [] FINISH, DestroyVDSCommand, log id: 1311bdbe 2018-01-18 14:33:47,449+02 INFO [org.ovirt.engine.core.vdsbroker.monitoring.VmAnalyzer] (ForkJoinPool-1-worker-5) [] VM '66bd9997-7a71-46b7-afcf-f7838bc9d366'(vm0) moved from 'WaitForLaunch' --> 'Down' 2018-01-18 14:33:47,527+02 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ForkJoinPool-1-worker-5) [] EVENT_ID: VM_DOWN_ERROR(119), VM vm0 is down with error. Exit message: unsupported configuration: Found duplicate drive address for disk with target name 'sdc' controller='0' bus='0' target='0' unit='3'. Additional logs are attached.