Bug 1536185 - transmission-2.92-11.fc27 breaks rpc setups
Summary: transmission-2.92-11.fc27 breaks rpc setups
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: transmission
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1536750 1536869 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-18 20:09 UTC by Peter Hjalmarsson
Modified: 2018-03-11 19:58 UTC (History)
15 users (show)

Fixed In Version: transmission-2.92-12.fc27 transmission-2.92-12.el7 transmission-2.92-12.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-30 18:05:31 UTC


Attachments (Terms of Use)
Patch adapter for 2.92, fetched from the PR (10.95 KB, patch)
2018-01-20 15:11 UTC, Peter Hjalmarsson
no flags Details | Diff

Description Peter Hjalmarsson 2018-01-18 20:09:17 UTC
Description of problem:
Since upgrade from 2.92-10 to 2.92-11 I cannot connect to the web-gui, nor kan transmission-remote connect to transmission from another computer then localhost.
This seems to have to do with how things are written to settings.json. After the update the following vars are always dupes in settings.json except the "withheld" passwords that are always new randomly generated.

    "rpc-password": "<withheld>",
    "rpc-password": "<withheld>",
    "rpc-port": 9091,
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-url": "/transmission/",
    "rpc-username": "",
    "rpc-username": "",
    "rpc-whitelist": "127.0.0.1",
    "rpc-whitelist": "127.0.0.1",
    "rpc-whitelist-enabled": true,
    "rpc-whitelist-enabled": true,


If I remove the dupes or change ny of the lines, new dupes are either created, or the lines are over-written.

Version-Release number of selected component (if applicable):
transmission-2.92-11.fc27

How reproducible:
Always

How to reproduce:
1. install transmission-2.92-11.fc27
2. edit the whitelist or disable whitelist in settings.json
3. start the daemon
4. try to access the daemon over network
5. verify how the whitelist looks


Actual results:
my conf (in Expected results) are overwritten on daemon restart with following:
    "rpc-password": "<withheld>",
    "rpc-password": "<withheld>",
    "rpc-port": 9091,
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-url": "/transmission/",
    "rpc-username": "",
    "rpc-username": "",
    "rpc-whitelist": "127.0.0.1",
    "rpc-whitelist": "127.0.0.1",
    "rpc-whitelist-enabled": true,
    "rpc-whitelist-enabled": true,


Expected results:
    "rpc-password": "<withheld>",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "",
    "rpc-whitelist": "127.0.0.1,10.88.*.*",
    "rpc-whitelist-enabled": true,


Additional info:
Even when I get the rpc-whitelist-enabled to say false, I still get 403 from the daemon, with comments in the web-ui about blocked by missing IP in whitelist.

Comment 1 mediaklan 2018-01-18 22:10:07 UTC
(In reply to Peter Hjalmarsson from comment #0)
Confirmed, as reported here : https://github.com/transmission/transmission/issues/473#event-1430874514
As Mikedld (github transmission maintainer) stated, looks like an earlier version of a patch (which had wrong order of quarks) was applied to this update.

Comment 2 Peter Hjalmarsson 2018-01-20 15:11:55 UTC
Created attachment 1383775 [details]
Patch adapter for 2.92, fetched from the PR

Cannot really see if the used patch is an older version or a try to make an own adaption of the upstream patch that did not get so well. However this is the patch posted by lfam in the PR as an adaption to 2.92.
Rebuilded with this patch instead, works fine.

Comment 3 seikainc 2018-01-21 04:29:12 UTC
Yes, I got the same duplicated lines in setting.json file on my production platform, Fedora 27.
Package version is 2.92-11.fc27

Comment 4 Peter Hjalmarsson 2018-01-22 15:15:58 UTC
CCing pbrobinson as he made the breaking commit.

Comment 5 Gwyn Ciesla 2018-01-22 15:19:12 UTC
*** Bug 1536869 has been marked as a duplicate of this bug. ***

Comment 6 Gwyn Ciesla 2018-01-22 15:19:22 UTC
*** Bug 1536750 has been marked as a duplicate of this bug. ***

Comment 7 Peter Hjalmarsson 2018-01-22 18:54:50 UTC
As the transmission testcases had fetched this, please add the following to the spec-file as well. I can verify that the current patch fails at "quark-test", however the patch i posted passes all tests.


--- transmission.spec.old	2018-01-22 19:51:34.248092816 +0100
+++ transmission.spec	2018-01-22 19:52:20.430198408 +0100
@@ -121,6 +121,9 @@
 	make %{?_smp_mflags}
 popd
 
+%check
+make %{?_smp_mflags} check
+
 %install
 mkdir -p %{buildroot}%{_unitdir}
 install -m0644 daemon/transmission-daemon.service  %{buildroot}%{_unitdir}/

Comment 8 Gwyn Ciesla 2018-01-23 15:03:09 UTC
Thank you, update coming.

Comment 9 Fedora Update System 2018-01-23 15:49:20 UTC
transmission-2.92-12.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b166805347

Comment 10 Fedora Update System 2018-01-23 15:49:46 UTC
transmission-2.92-12.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-499a02cc9d

Comment 11 Fedora Update System 2018-01-23 16:24:38 UTC
transmission-2.92-12.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-c0d5d190b0

Comment 12 Fedora Update System 2018-01-23 22:29:19 UTC
transmission-2.92-12.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-c0d5d190b0

Comment 13 Fedora Update System 2018-01-23 22:51:11 UTC
transmission-2.92-12.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b166805347

Comment 14 Fedora Update System 2018-01-23 23:43:08 UTC
transmission-2.92-12.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-499a02cc9d

Comment 15 seikainc 2018-01-27 02:29:10 UTC
(In reply to Fedora Update System from comment #14)
> transmission-2.92-12.fc27 has been pushed to the Fedora 27 testing
> repository. If problems still persist, please make note of it in this bug
> report.
> See https://fedoraproject.org/wiki/QA:Updates_Testing for
> instructions on how to install test updates.
> You can provide feedback for this update here:
> https://bodhi.fedoraproject.org/updates/FEDORA-2018-499a02cc9d

Upgraded to 2.92-12.fc27 from testing repo using dnf and the settings.json file is OK, no duplicate lines.

Comment 16 Fedora Update System 2018-01-30 18:05:31 UTC
transmission-2.92-12.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2018-02-07 12:38:07 UTC
transmission-2.92-12.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2018-03-11 19:58:04 UTC
transmission-2.92-12.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.