Bug 1536300 - Live Migration: Engine fails to pass the destination Host parameter when user shuts down VM in the middle of migration
Summary: Live Migration: Engine fails to pass the destination Host parameter when user...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.8
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.1
: ---
Assignee: Michal Skrivanek
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On: 1505399
Blocks: 1540914
TreeView+ depends on / blocked
 
Reported: 2018-01-19 05:15 UTC by Anitha Udgiri
Modified: 2021-06-10 14:16 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1540914 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:47:24 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3347121 0 None None None 2018-02-07 17:44:21 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:48:17 UTC

Description Anitha Udgiri 2018-01-19 05:15:44 UTC
Description of problem:
When a VM being migrated from Host A to Host B is shutdown manually by a user before the migration completes, although VM status is "Down" , engine fails to pass the destination Host parameter .

The VM ends up being in  "MigratingTo" state without any associated Host.

It fails to let any other operation on it until manual DB intervention.

Version-Release number of selected component (if applicable):
rhevm-4.1.8.2-0.1.el7.noarch 




Additional info:

Comment 3 Michal Skrivanek 2018-01-22 13:36:04 UTC
looks like a duplicate of bug 1505399

Comment 4 RHV bug bot 2018-01-26 19:17:48 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.1.z': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.1.z': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 5 RHV bug bot 2018-01-30 14:00:43 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found clone flags: ['rhevm-4.1.z', 'rhevm-4.2-ga'], ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found clone flags: ['rhevm-4.1.z', 'rhevm-4.2-ga'], ]

For more info please contact: rhv-devops@redhat.com

Comment 7 RHV bug bot 2018-02-02 22:05:28 UTC
INFO: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 8 Israel Pinto 2018-02-11 14:03:38 UTC
Verify with:
Engine: Software Version:4.2.1.6-0.1.el7
Host: 
OS Version:RHEL - 7.4 - 18.el7
Kernel Version:3.10.0 - 693.17.1.el7.x86_64
KVM Version:2.9.0 - 16.el7_4.14
LIBVIRT Version:libvirt-3.9.0-8.el7
VDSM Version:vdsm-4.20.17-1.el7ev


Steps:
1. Start vm 
2. Migration VM
3. While migration start , state "migrateTo" - Stop VM

Results:
VM stopped, VM not exist on any host.

Comment 14 errata-xmlrpc 2018-05-15 17:47:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 15 Franta Kust 2019-05-16 13:06:40 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.