Bug 1536653 - mariadb 10.2.10-2 -> 10.2.12-2 update transaction fails
Summary: mariadb 10.2.10-2 -> 10.2.12-2 update transaction fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1537149 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-19 20:39 UTC by Rex Dieter
Modified: 2018-02-04 21:50 UTC (History)
9 users (show)

Fixed In Version: mariadb-10.2.12-5.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-04 21:50:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Rex Dieter 2018-01-19 20:39:22 UTC
dnf update:


Last metadata expiration check: 0:09:50 ago on Fri 19 Jan 2018 02:25:29 PM CST.
Dependencies resolved.

 Problem 1: cannot install both mariadb-server-3:10.2.12-2.fc27.x86_64 and mariadb-server-3:10.2.10-2.fc27.x86_64
  - package mariadb-tokudb-engine-3:10.2.10-2.fc27.x86_64 requires mariadb-server(x86-64) = 3:10.2.10-2.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package mariadb-server-3:10.2.10-2.fc27.x86_64
  - problem with installed package mariadb-tokudb-engine-3:10.2.10-2.fc27.x86_64
 Problem 2: cannot install both mariadb-server-3:10.2.12-2.fc27.x86_64 and mariadb-server-3:10.2.10-2.fc27.x86_64
  - package mariadb-tokudb-engine-3:10.2.10-2.fc27.x86_64 requires mariadb-server(x86-64) = 3:10.2.10-2.fc27, but none of the providers can be installed
  - package mariadb-backup-3:10.2.12-2.fc27.x86_64 requires mariadb-server(x86-64) = 3:10.2.12-2.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package mariadb-tokudb-engine-3:10.2.10-2.fc27.x86_64
  - cannot install the best update candidate for package mariadb-backup-3:10.2.10-2.fc27.x86_64
================================================================================================================================================================================
 Package                                    Arch                               Version                                        Repository                                   Size
================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 mariadb-server                             x86_64                             3:10.2.12-2.fc27                               updates-testing                              17 M
Skipping packages with broken dependencies:
 mariadb-backup                             x86_64                             3:10.2.12-2.fc27                               updates-testing                             5.8 M

Transaction Summary
================================================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!

Comment 1 Rex Dieter 2018-01-19 20:44:40 UTC
Looks like tokudb support was disabled since 10.2.10, but there are no Obsoletes: in place to handle the upgrade path

Comment 2 Rex Dieter 2018-01-19 20:49:03 UTC
probably want to do something like change

Recommends:  %{name}-tokudb-engine%{?_isa} = %{sameevr}

to

%if %{with tokudb}
Recommends: %{name}-tokudb-engine%{?_isa} = %{sameevr}
%else
Obsoletes: %{name}-tokudb-engine < 3:10.2.12
%endif

Comment 3 Michal Schorm 2018-01-19 20:58:22 UTC
Yes,
the problem is clearly that TokuDB subpackage is not provided in the 10.2.12.

It suffered with heavy issues that either lead to FTBFS, testsuite freeze or >500 tests failures. (none should fail)
Beacuse of that state, I decided to provide 10.2.12 update without TokuDB subpackage.

Which clearly wasn't correct, as I see now.

Comment 4 Michal Schorm 2018-01-24 21:10:45 UTC
*** Bug 1537149 has been marked as a duplicate of this bug. ***

Comment 5 Michal Schorm 2018-01-24 21:11:33 UTC
Working on it, with upstream
https://jira.mariadb.org/browse/MDEV-15034

Comment 6 Fedora Update System 2018-01-27 11:11:22 UTC
mariadb-10.2.12-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 7 Fedora Update System 2018-01-28 23:05:22 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 8 Fedora Update System 2018-01-29 09:27:58 UTC
mariadb-10.2.12-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 9 Fedora Update System 2018-01-29 19:08:48 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 10 Fedora Update System 2018-02-04 21:50:20 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.