Bug 1536868 - RHOSP12 deployment fails with Ceph and RGW enabled because ceph-rgw is listening on 0.0.0.0:8080
Summary: RHOSP12 deployment fails with Ceph and RGW enabled because ceph-rgw is listen...
Status: CLOSED DUPLICATE of bug 1536074
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ceph
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Ian Colle
QA Contact: Warren
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-21 20:19 UTC by Rafal Szmigiel
Modified: 2018-01-23 10:38 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-01-23 10:38:27 UTC


Attachments (Terms of Use)

Description Rafal Szmigiel 2018-01-21 20:19:31 UTC
Description of problem:

RHOSP12 deployment with Ceph and RGW enabled fails because ceph-rgw is listening on 0.0.0.0:8080. In a result haproxy cannot bind to ${VIP}:8080 and fails to start.

[root@overcloud-controller-0 ceph]# netstat -nlp | grep 427687
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      427687/radosgw      

[root@overcloud-controller-0 ceph]# ps aux | grep 427687
ceph      427687  0.3  0.0 5888604 15412 ?       Ssl  20:04   0:00 /usr/bin/radosgw --cluster ceph --setuser ceph --setgroup ceph -d -n client.rgw.overcloud-controller-0 -k /var/lib/ceph/radosgw/overcloud-controller-0/keyring --rgw-socket-path= --rgw-zonegroup= --rgw-zone= --rgw-frontends=civetweb port=8080


[root@overcloud-controller-0 ceph]# pcs status
Cluster name: tripleo_cluster
Stack: corosync
Current DC: overcloud-controller-0 (version 1.1.16-12.el7_4.5-94ff4df) - partition with quorum
Last updated: Sun Jan 21 20:09:30 2018
Last change: Sun Jan 21 20:08:39 2018 by root via cibadmin on overcloud-controller-0

4 nodes configured
16 resources configured

Online: [ overcloud-controller-0 ]
GuestOnline: [ galera-bundle-0@overcloud-controller-0 rabbitmq-bundle-0@overcloud-controller-0 redis-bundle-0@overcloud-controller-0 ]

Full list of resources:

 Docker container: rabbitmq-bundle [192.168.111.1:8787/rhosp12/openstack-rabbitmq:pcmklatest]
   rabbitmq-bundle-0    (ocf::heartbeat:rabbitmq-cluster):      Started overcloud-controller-0
 Docker container: galera-bundle [192.168.111.1:8787/rhosp12/openstack-mariadb:pcmklatest]
   galera-bundle-0      (ocf::heartbeat:galera):        Master overcloud-controller-0
 Docker container: redis-bundle [192.168.111.1:8787/rhosp12/openstack-redis:pcmklatest]
   redis-bundle-0       (ocf::heartbeat:redis): Master overcloud-controller-0
 ip-192.168.111.208     (ocf::heartbeat:IPaddr2):       Stopped
 ip-192.168.122.10      (ocf::heartbeat:IPaddr2):       Stopped
 ip-172.17.0.16 (ocf::heartbeat:IPaddr2):       Stopped
 ip-172.17.0.10 (ocf::heartbeat:IPaddr2):       Stopped
 ip-172.18.0.17 (ocf::heartbeat:IPaddr2):       Stopped
 ip-172.19.0.11 (ocf::heartbeat:IPaddr2):       Stopped
 Docker container: haproxy-bundle [192.168.111.1:8787/rhosp12/openstack-haproxy:pcmklatest]
   haproxy-bundle-docker-0      (ocf::heartbeat:docker):        Stopped

Failed Actions:
* haproxy-bundle-docker-0_start_0 on overcloud-controller-0 'unknown error' (1): call=349, status=complete, exitreason='Newly created docker container exited after start',
    last-rc-change='Sun Jan 21 20:08:43 2018', queued=0ms, exec=1466ms


Daemon Status:
  corosync: active/enabled
  pacemaker: active/enabled
  pcsd: active/enabled




Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: INFO:__main__:Loading config file at /var/lib/kolla/config_files/config.json
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: INFO:__main__:Validating config file
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: INFO:__main__:Kolla config strategy set to: COPY_ALWAYS
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: INFO:__main__:Copying service configuration files
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: INFO:__main__:Deleting /etc/haproxy/haproxy.cfg
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: INFO:__main__:Copying /var/lib/kolla/config_files/src/etc/haproxy/haproxy.cfg to /etc/haproxy/haproxy.cfg
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: INFO:__main__:Copying /var/lib/kolla/config_files/src-tls/etc/pki/tls/private/overcloud_endpoint.pem to /etc/pki/tls/private/ov
ercloud_endpoint.pem
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: INFO:__main__:Writing out command to execute
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: Running command: '/usr/sbin/haproxy-systemd-wrapper -f /etc/haproxy/haproxy.cfg'
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: <7>haproxy-systemd-wrapper: executing /usr/sbin/haproxy -f /etc/haproxy/haproxy.cfg -Ds 
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: [WARNING] 020/200843 (10) : Setting tune.ssl.default-dh-param to 1024 by default, if your workload permits it you should set it
 to at least 2048. Please set a value >= 1024 to make this warning disappear.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy aodh started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy cinder started.
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: [ALERT] 020/200843 (10) : Starting proxy ceph_rgw: cannot bind socket [172.18.0.17:8080]
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy glance_api started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy gnocchi started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy haproxy.stats started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy heat_api started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy heat_cfn started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy horizon started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy keystone_admin started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy keystone_public started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy mysql started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy neutron started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy nova_metadata started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy nova_novncproxy started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy nova_osapi started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy nova_placement started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy panko started.
Jan 21 20:08:43 overcloud-controller-0 haproxy[438205]: Proxy redis started.
Jan 21 20:08:43 overcloud-controller-0 dockerd-current[18861]: <5>haproxy-systemd-wrapper: exit, haproxy RC=1
Jan 21 20:08:43 overcloud-controller-0 docker(haproxy-bundle-docker-0)[438218]: INFO: monitor cmd exit code = 1
Jan 21 20:08:43 overcloud-controller-0 docker(haproxy-bundle-docker-0)[438226]: INFO: stdout/stderr: nsenter: cannot open /proc/438153/ns/ipc: No such file or directory
Jan 21 20:08:43 overcloud-controller-0 docker(haproxy-bundle-docker-0)[438238]: ERROR: waiting on monitor_cmd to pass after start



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Giulio Fidente 2018-01-23 10:38:27 UTC

*** This bug has been marked as a duplicate of bug 1536074 ***


Note You need to log in before you can comment on or make changes to this bug.