Bug 1537153 - iSCSI deployment of node zero fails with "'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'int object' has no attribute 'split'"}".
Summary: iSCSI deployment of node zero fails with "'ansible.errors.AnsibleUndefinedVar...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.Block
Version: 2.2.6
Hardware: x86_64
OS: Linux
unspecified
urgent vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1455169 1458709
TreeView+ depends on / blocked
 
Reported: 2018-01-22 14:51 UTC by Nikolai Sednev
Modified: 2018-02-12 11:53 UTC (History)
3 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 11:53:30 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2?
sbonazzo: blocker?
nsednev: planning_ack?
sbonazzo: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
sosreport from alma04 (9.54 MB, application/x-xz)
2018-01-22 14:55 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 86663 master MERGED ansible: iSCSI: remove not needed cast on iSCSI port 2018-09-03 09:36:22 UTC

Description Nikolai Sednev 2018-01-22 14:51:32 UTC
Description of problem:
[ INFO  ] TASK [Add iSCSI storage domain]
[ ERROR ] fatal: [localhost]: FAILED! => {"msg": "The task includes an option with an undefined variable. The error was: 'int object' has no attribute 'split'\n\nThe error appears to have been in '/usr/share/ovirt-hosted-engine-setup/ansible/create_storage_domain.yml': line 63, column 5, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n    register: otopi_storage_domain_details\n  - name: Add iSCSI storage domain\n    ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'int object' has no attribute 'split'"}
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: 


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.2.7-0.0.master.20180119084226.git3799ea2.el7.centos.noarch
ovirt-hosted-engine-ha-2.2.5-0.0.master.20180117160214.20180117160210.gitd5b58a8.el7.centos.noarch
ovirt-engine-appliance.noarch

How reproducible:
100%

Steps to Reproduce:
1.Deploy Node Zero over iSCSI.

Actual results:
Deployment fails.

Expected results:
Deployment should succeed.

Additional info:
see attached sosreport from clean host alma04.

Comment 1 Nikolai Sednev 2018-01-22 14:52:51 UTC
See more details about deployment here http://pastebin.test.redhat.com/548881

Comment 2 Nikolai Sednev 2018-01-22 14:55:08 UTC
Created attachment 1384481 [details]
sosreport from alma04

Comment 3 Nikolai Sednev 2018-01-28 15:01:43 UTC
Did not reproduced on these components:
ovirt-hosted-engine-ha-2.2.5-0.0.master.20180125081710.20180125081707.git6046986.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.9-0.0.master.20180124164059.git097610a.el7.centos.noarch
ovirt-engine-appliance-4.2-20180127.1.el7.centos.noarch

Moving to verified.

Comment 4 Sandro Bonazzola 2018-02-12 11:53:30 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.