Bug 153716 - HP PSC 2175: device not detected
HP PSC 2175: device not detected
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hpoj (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-05 03:40 EDT by Bruno De Wolf
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 05:26:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno De Wolf 2005-04-05 03:40:54 EDT
Description of problem:
Currently using FC3 with most recent updates (4.4.2005). Printing to my HP
multifunctional PSC2175 fails. Apparently the printer is not detected by the
printing system, although it is properly connected. The printer worked perfectly
under FC2 with hpoj and (I think) early versions of FC3.
Main symptoms:
- lsusb shows the printer
- ptal-init setup does not detect any printer
I tried to install hplip instead of hpoj (download source; configure
--prefix=/usr/local; make; make install), but alse hp-probe does not detect any
printer.

Version-Release number of selected component (if applicable):
hpoj-0.91-9, hpijs-1.6-2, kernel 2.6.10-1.770_FC3

How reproducible:
always

Steps to Reproduce:
1. lsusb
[root@orac ~]# lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 03f0:2b11 Hewlett-Packard
Bus 001 Device 002: ID 046d:c016 Logitech, Inc.
Bus 001 Device 001: ID 0000:0000
2. ptal-init setup
...
Probe for USB-connected devices ([y]/n)?  y

Probing "%002%001"...
    No device found.

Probing "%001%003"...
    No device found.

Probing "%001%002"...
    No device found.

Probing "%001%001"...
    No device found.


  
Actual results:


Expected results:
Printer should be detected.

Additional info:

tail /var/log/messages after ptal-init setup:
Apr  5 09:16:12 localhost cups: cupsd startup succeeded
Apr  5 09:16:22 localhost ptal-mlcd: SYSLOG at ExMgr.cpp:652,
dev=<mlc:usb:probe>, pid=5600, e=2, t=1112685382         ptal-mlcd successfully
initialized.
Apr  5 09:16:22 localhost ptal-mlcd: SYSLOG at ExMgr.cpp:652,
dev=<mlc:usb:probe>, pid=5607, e=111, t=1112685382         ptal-mlcd
successfully initialized.
Apr  5 09:16:22 localhost ptal-mlcd: ERROR at ExMgr.cpp:2525,
dev=<mlc:usb:probe>, pid=5607, e=11, t=1112685382         Couldn't find device!
Apr  5 09:16:22 localhost ptal-mlcd: SYSLOG at ExMgr.cpp:652,
dev=<mlc:usb:probe>, pid=5616, e=111, t=1112685382         ptal-mlcd
successfully initialized.
Apr  5 09:16:22 localhost ptal-mlcd: ERROR at ExMgr.cpp:2525,
dev=<mlc:usb:probe>, pid=5616, e=16, t=1112685382         Couldn't find device!
Apr  5 09:16:22 localhost ptal-mlcd: SYSLOG at ExMgr.cpp:652,
dev=<mlc:usb:probe>, pid=5625, e=111, t=1112685382         ptal-mlcd
successfully initialized.
Apr  5 09:16:22 localhost ptal-mlcd: ERROR at ExMgr.cpp:2525,
dev=<mlc:usb:probe>, pid=5625, e=11, t=1112685382         Couldn't find device!
Apr  5 09:16:22 localhost ptal-mlcd: SYSLOG at ExMgr.cpp:652,
dev=<mlc:usb:probe>, pid=5634, e=111, t=1112685382         ptal-mlcd
successfully initialized.
Apr  5 09:16:22 localhost ptal-mlcd: ERROR at ExMgr.cpp:2525,
dev=<mlc:usb:probe>, pid=5634, e=11, t=1112685382         Couldn't find device!


When using hplip:
[root@orac ~]# /usr/local/bin/hp-probe

 HP Linux Imaging and Printing System (ver. 0.9.1)
 Device Detection (Probe) Utility ver. 1.1

 Copyright (c) 2003-5 Hewlett-Packard Development Company, LP
 This software comes with ABSOLUTELY NO WARRANTY.
 This is free software, and you are welcome to distribute it
 under certain conditions. See COPYING file for more details.

 [WARNING]: No devices found. If this isn't the result you are expecting,
 [WARNING]: check to make sure your devices are properly connected.
[root@orac ~]# tail /var/log/messages
Apr  5 09:05:33 localhost scsi.agent[5185]: disk at
/devices/pci0000:00/0000:00:1f.2/usb1/1-1/1-1:1.3/host0/target0:0:0/0:0:0:0
Apr  5 09:05:33 localhost kernel: Attached scsi removable disk sda at scsi0,
channel 0, id 0, lun 0
Apr  5 09:05:59 localhost su(pam_unix)[5279]: session opened for user root by
bruno(uid=500)
Apr  5 09:08:22 localhost kernel: usb 1-2: usbfs: process 5368 (lsusb) did not
claim interface 0 before use
Apr  5 09:08:57 localhost python: hpssd [WARN] Inrecognized URI: parallel:/dev/lp0
Apr  5 09:08:57 localhost python: hpssd [WARN] Inrecognized URI:
hal:///org/freedesktop/Hal/devices/usb_usb_device_3f0_2b11_100_-1_MY37IF80TR73_1
Apr  5 09:08:57 localhost python: hpssd [WARN] Inrecognized URI:
hal:///org/freedesktop/Hal/devices/usb_usb_device_3f0_2b11_100_-1_MY37IF80TR73_1
Apr  5 09:08:57 localhost python: hpssd [WARN] Inrecognized URI:
ptal:/mlc:usb:PSC_2170_Series
Apr  5 09:08:57 localhost python:  [WARN] No devices found. If this isn't the
result you are expecting,
Apr  5 09:08:57 localhost python:  [WARN] check to make sure your devices are
properly connected.




lsusb -v relevant extract:
Bus 001 Device 003: ID 03f0:2b11 Hewlett-Packard
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x03f0 Hewlett-Packard
  idProduct          0x2b11
  bcdDevice            1.00
  iManufacturer           1 Hewlett-Packard
  iProduct                2 PSC 2170 Series
  iSerial                 3 MY37IF80TR73
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength          122
    bNumInterfaces          4
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xc0
      Self Powered
    MaxPower                2mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    204
      bInterfaceProtocol      0
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0008  bytes 8 once
        bInterval              10
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass         7 Printer
      bInterfaceSubClass      1 Printer
      bInterfaceProtocol      2 Bidirectional
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x03  EP 3 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x84  EP 4 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0008  bytes 8 once
        bInterval              10
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        2
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x05  EP 5 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x85  EP 5 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x86  EP 6 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0008  bytes 8 once
        bInterval              10
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        3
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk (Zip)
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x07  EP 7 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0020  bytes 32 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x87  EP 7 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0020  bytes 32 once
        bInterval               0
  Language IDs: (length=4)
     0409 English(US)


Thank you for helping,

Bruno
Comment 1 Tim Waugh 2005-04-06 06:35:15 EDT
Hopefully this is something that hplip will fix when we switch to it.
Comment 2 Bruno De Wolf 2005-04-19 14:41:01 EDT
Is hplip included in FC4T2? I couldn't find this in the package list.
Comment 3 Tim Waugh 2005-04-20 04:24:11 EDT
No, it isn't.  FC5.
Comment 4 Bruno De Wolf 2005-04-21 09:49:11 EDT
Whoops, this is quite a long time for me to wait (especially since hpoj was
working well in FC2). What do you suggest? I report this issue to the hplip
developers? Other?

Thanks for your feedback,

Bruno


Comment 5 Bruno De Wolf 2005-04-22 04:29:01 EDT
This is solved.

Apparently, /dev/usb/lp* was not available
After a MAKEDEV usb in /dev, everything was ok.


Note You need to log in before you can comment on or make changes to this bug.