Bug 1537184 - infra: install libtirpc-devel and rpcgen on jenkins hosts
Summary: infra: install libtirpc-devel and rpcgen on jenkins hosts
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-22 16:07 UTC by Kaleb KEITHLEY
Modified: 2018-08-13 04:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-13 04:05:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1536186 None None None Never
Red Hat Bugzilla 1536187 None None None Never

Internal Links: 1536186 1536187

Description Kaleb KEITHLEY 2018-01-22 16:07:32 UTC
Description of problem:

Newer glibc is removing rpc headers and rpcgen. The designated path forward is to use libtirpc-devel for rpc headers and rpcgen (currently from glibc-rpcgen, and soon from the rpcsvc-proto rpcgen sub-package.) 

As distributions like Fedora-28/rawhide update to new glibc they will need libtirpc-devel and rpgen explicitly.

In the mean time we need at least libtirpc-devel installed on our jenkins hosts as mainline and release-3.13 branches will want to build with with it instead of the legacy glibc rpc headers and lib.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nigel Babu 2018-02-01 09:25:32 UTC
I'm going to delay this until we switch out regression infra to centos 7.

Comment 2 Nigel Babu 2018-03-01 04:45:25 UTC
So installing this means that we'll fail to compile on Centos 7. Do we want this in that case on our regression nodes?

Comment 3 Kaleb KEITHLEY 2018-03-01 12:25:50 UTC
it won't fail to compile. It won't use it at all on rhel/centos.

It will only use it on fedora 28 at this point.

I thought rhel7/centos7 would have the right version. Turns out I was mistaken.

Installing it on rhel/centos is a no-op. Maybe the right version will be in 7.6.

Comment 4 Nigel Babu 2018-08-13 04:05:09 UTC
Given we now have Fedora builds which actually use this, I'm going to close this bug.


Note You need to log in before you can comment on or make changes to this bug.