Bug 1537479 - Add Azure disk default storage class in installation
Summary: Add Azure disk default storage class in installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-23 10:13 UTC by Wenqi He
Modified: 2018-07-30 19:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Environments where the Azure cloud provider is enabled now provision a default storage class for use with Azure storage.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:09:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:34 UTC

Description Wenqi He 2018-01-23 10:13:02 UTC
Description of problem:
Like other IAAS, in Azure cloud provider env, we also need a default storage class for every product

Version-Release number of the following components:
rpm -q openshift-ansible
openshift-ansible-3.9.0-0.22.0.git.0.0e9d896.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install cloud provider env on Azure
2.
3.

Actual results:
There is no default storage class

Expected results:
There should be a default storage class with azure-disk

$ cat sc.yaml
kind: StorageClass
apiVersion: storage.k8s.io/v1
metadata:
  name: azddef
  annotations:
    storageclass.beta.kubernetes.io/is-default-class: "true"
provisioner: kubernetes.io/azure-disk
parameters:
  kind: Shared

Additional info:

Comment 5 Scott Dodson 2018-05-02 18:39:07 UTC
Moving to ON_QA based on the community work contributed in comment 4, thanks!

In openshift-ansible-3.10.0-0.22.0 and later.

Comment 6 Wenqi He 2018-05-03 07:40:17 UTC
Tested on below version:
openshift v3.10.0-0.32.0
kubernetes v1.10.0+b81c8f8

Now Azure has default storage class of azure disk.
# oc get sc
NAME                       PROVISIONER                AGE
azure-standard (default)   kubernetes.io/azure-disk   4h

Tried to create a pvc, it works
# oc get pvc
NAME          STATUS    VOLUME                                     CAPACITY   ACCESS MODES   STORAGECLASS     AGE
azpvc         Bound     pvc-b245bb71-4ea4-11e8-b97c-000d3a1acd47   1Gi        RWO            azure-standard   1m

Comment 8 errata-xmlrpc 2018-07-30 19:09:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.