Bug 1537603 - ovirt-engine-setup-plugin-vmconsole-proxy-helper is not re-asking to be enabled if once set to False
Summary: ovirt-engine-setup-plugin-vmconsole-proxy-helper is not re-asking to be enabl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.2
: ---
Assignee: Ido Rosenzwig
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-23 15:19 UTC by Andreas Bleischwitz
Modified: 2021-09-09 13:07 UTC (History)
11 users (show)

Fixed In Version: ovirt-engine-4.2.2
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-05-15 17:47:24 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHV-43474 0 None None None 2021-09-09 13:07:48 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:48:17 UTC
oVirt gerrit 86899 0 master MERGED packaging: setup: Make 'VM Console Proxy' reconfigurable 2018-01-30 08:53:01 UTC

Description Andreas Bleischwitz 2018-01-23 15:19:12 UTC
Description of problem:
After engine-setup has been run and configured without vmconsole-proxy, it is no longer possible to enable vmconsole-proxy. Even though engine-setup has "--reconfigure-optional-components" which should re-ask for initially disabled components, the console is left as disabled.

Version-Release number of selected component (if applicable):
# rpm -qa ovirt-engine-setup-plugin-vmconsole\*
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.2.0.2-0.1.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. run engine-setup - answer "no" to vmconsole setup
2. re-run "engine-setup --reconfigure-optional-components", find "Configure VMConsole Proxy" set to False without further asking

Actual results:
No question on the reconfiguration:
--== PRODUCT OPTIONS ==--

--== PACKAGES ==--


Expected results:
Get questioned if VN Console Proxy should be configured:
--== PRODUCT OPTIONS ==--
         
          Configure VM Console Proxy on this host (Yes, No) [Yes]:

--== PACKAGES ==--

Additional info:

Comment 2 Jan Zmeskal 2018-02-19 15:56:07 UTC
Verified on:
Name        : ovirt-engine-setup-plugin-vmconsole-proxy-helper
Version     : 4.2.2
Release     : 0.1.el7
Architecture: noarch
Install Date: Mon 19 Feb 2018 03:56:09 PM CET
Group       : Virtualization/Management
Size        : 86787
License     : ASL 2.0
Signature   : (none)
Source RPM  : ovirt-engine-4.2.2-0.1.el7.src.rpm
Build Date  : Thu 15 Feb 2018 06:18:11 PM CET
Build Host  : x86-040.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://www.redhat.com/products/virtualization
Summary     : Setup and upgrade specific plugins for vmconsole-proxy-helper
Description :
Setup and upgrade specific plugins for vmconsole-proxy-helper

Verification steps:
I followed Reproduction steps provided in Description. I can confirm that "Configure VM Console Proxy on this host" appears in re-run of engine-setup now if it was set to False first time and then engine-setup is run with --reconfigure-optional-components parameter.

Comment 3 RHV bug bot 2018-03-16 15:01:45 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Tag 'ovirt-engine-4.2.2.4' doesn't contain patch 'https://gerrit.ovirt.org/86899']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.2.2.4

For more info please contact: rhv-devops@redhat.com

Comment 7 errata-xmlrpc 2018-05-15 17:47:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 8 Franta Kust 2019-05-16 13:05:57 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.