Bug 1537957 - [abrt] dnf: _add_from_xml_filename(): comps.py:328:_add_from_xml_filename:_libpycomps.ParserError: Fatal parser error
Summary: [abrt] dnf: _add_from_xml_filename(): comps.py:328:_add_from_xml_filename:_li...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Blaha
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e06494d434f11fb436ab70bdf99...
Keywords: Triaged
: 1538018 1538036 1538151 1538166 1544407 1586014 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-24 07:41 UTC by Elizabeth Pratt
Modified: 2018-06-28 08:24 UTC (History)
17 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-06-28 08:24:29 UTC


Attachments (Terms of Use)
File: _var_log_dnf.log (381.92 KB, text/plain)
2018-01-24 07:41 UTC, Elizabeth Pratt
no flags Details
File: backtrace (1.49 KB, text/plain)
2018-01-24 07:41 UTC, Elizabeth Pratt
no flags Details
File: cgroup (355 bytes, text/plain)
2018-01-24 07:41 UTC, Elizabeth Pratt
no flags Details
File: cpuinfo (1.09 KB, text/plain)
2018-01-24 07:41 UTC, Elizabeth Pratt
no flags Details
File: dnf-makecache.log (425 bytes, text/plain)
2018-01-24 07:41 UTC, Elizabeth Pratt
no flags Details
File: environ (3.22 KB, text/plain)
2018-01-24 07:41 UTC, Elizabeth Pratt
no flags Details
File: mountinfo (3.58 KB, text/plain)
2018-01-24 07:42 UTC, Elizabeth Pratt
no flags Details
File: namespaces (129 bytes, text/plain)
2018-01-24 07:42 UTC, Elizabeth Pratt
no flags Details
File: open_fds (729 bytes, text/plain)
2018-01-24 07:42 UTC, Elizabeth Pratt
no flags Details

Description Elizabeth Pratt 2018-01-24 07:41:44 UTC
Version-Release number of selected component:
dnf-2.7.5-2.fc27

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnf group
crash_function: _add_from_xml_filename
exception_type: _libpycomps.ParserError
executable:     /usr/bin/dnf
kernel:         4.14.14-300.fc27.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
comps.py:328:_add_from_xml_filename:_libpycomps.ParserError: Fatal parser error

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 1014, in run
    return self.command.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/group.py", line 375, in run
    self._grp_setup()
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/group.py", line 108, in _grp_setup
    self.base.read_comps(arch_filter=True)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 550, in read_comps
    self._comps._add_from_xml_filename(decompressed)
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 328, in _add_from_xml_filename
    ret = comps.fromxml_f(fn)
_libpycomps.ParserError: Fatal parser error

Local variables in innermost frame:
comps: <_libpycomps.Comps object at 0x7f2542c98b70>
fn: '/var/tmp/dnf-elzi-qogip5ia/updates-09879b494aeba108/repodata/gen/groups.xml'
self: <dnf.comps.Comps object at 0x7f2542ce65f8>

Comment 1 Elizabeth Pratt 2018-01-24 07:41:52 UTC
Created attachment 1385286 [details]
File: _var_log_dnf.log

Comment 2 Elizabeth Pratt 2018-01-24 07:41:53 UTC
Created attachment 1385287 [details]
File: backtrace

Comment 3 Elizabeth Pratt 2018-01-24 07:41:54 UTC
Created attachment 1385288 [details]
File: cgroup

Comment 4 Elizabeth Pratt 2018-01-24 07:41:55 UTC
Created attachment 1385289 [details]
File: cpuinfo

Comment 5 Elizabeth Pratt 2018-01-24 07:41:56 UTC
Created attachment 1385290 [details]
File: dnf-makecache.log

Comment 6 Elizabeth Pratt 2018-01-24 07:41:58 UTC
Created attachment 1385291 [details]
File: environ

Comment 7 Elizabeth Pratt 2018-01-24 07:42:00 UTC
Created attachment 1385292 [details]
File: mountinfo

Comment 8 Elizabeth Pratt 2018-01-24 07:42:01 UTC
Created attachment 1385293 [details]
File: namespaces

Comment 9 Elizabeth Pratt 2018-01-24 07:42:02 UTC
Created attachment 1385294 [details]
File: open_fds

Comment 10 Adam Williamson 2018-01-24 08:19:38 UTC
Similar problem has been detected:

This can be triggered by just running 'dnf groupinstall base-x' from a Fedora 27 system. It started happening between 19 hours ago and 10 hours ago. I think it's a problem with the repo metadata, as it can be triggered on a system which wasn't updated in that time frame.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /bin/dnf groupinstall base-x
crash_function: _add_from_xml_filename
exception_type: _libpycomps.ParserError
executable:     /bin/dnf
kernel:         4.14.13-300.fc27.x86_64
package:        dnf-2.7.5-2.fc27
reason:         comps.py:328:_add_from_xml_filename:_libpycomps.ParserError: Fatal parser error
runlevel:       N 5
type:           Python3
uid:            0

Comment 11 FlyDove 2018-01-24 10:28:59 UTC
*** Bug 1538018 has been marked as a duplicate of this bug. ***

Comment 12 Adam Williamson 2018-01-24 11:38:37 UTC
Note, this was caused by bad repodata (empty comps.xml) making it out to the mirrors; apparently there was an NFS hiccup during the sync which caused this to happen. releng is running an emergency update push to clear up the problem. Will leave the bug open just in case DNF folks think it makes sense to handle this case a bit more cleanly (i.e. not just crash on the parser exception but handle or pre-empt it somehow).

Comment 13 Ahmed Hosny 2018-01-24 14:59:57 UTC
*** Bug 1538166 has been marked as a duplicate of this bug. ***

Comment 14 Ahmed Hosny 2018-01-24 15:41:25 UTC
Just did `dnf clean metadata` then `dnf update` and the problem resolved.

Comment 15 Marek Blaha 2018-01-25 08:45:40 UTC
*** Bug 1538151 has been marked as a duplicate of this bug. ***

Comment 17 Daniel Mach 2018-01-31 12:06:53 UTC
*** Bug 1538036 has been marked as a duplicate of this bug. ***

Comment 18 Marek Blaha 2018-02-13 06:21:49 UTC
*** Bug 1544407 has been marked as a duplicate of this bug. ***

Comment 19 Marek Blaha 2018-06-11 13:32:19 UTC
*** Bug 1586014 has been marked as a duplicate of this bug. ***

Comment 20 Jaroslav Mracek 2018-06-28 08:24:29 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.