Bug 1538006 - Should give some prompt instead of no any response when origin-web-console pod is not ready
Summary: Should give some prompt instead of no any response when origin-web-console po...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.9.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-24 09:49 UTC by shahan
Modified: 2019-06-04 20:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 20:07:13 UTC


Attachments (Terms of Use)

Description shahan 2018-01-24 09:49:06 UTC
Description of problem:
Should give some prompt instead of no any response when origin-web-console pod is not ready

Version-Release number of selected component (if applicable):
v3.9.0-0.23.0

How reproducible:
Always

Steps to Reproduce:
1. Make origin-web-console pod not ready, e.g. scale down replicas to 0

2. Input web console url in browser address bar and press Enter

Actual results:
2. No response and prompt

Expected results:
2. Should give some prompt "*** is not available" like route (e.g. bug 1414657)

Additional info:

Comment 1 openshift-github-bot 2018-03-11 02:51:24 UTC
Commits pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/0722cb00c273a097dbd357ef48a2c0fc56981de4
Bug 1538006 - Improve error page when console not installed

Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1538006

https://github.com/openshift/origin/commit/bf0cf427d1c1fc768e3f5516d70b66309c027e4e
Merge pull request #18680 from spadgett/console-error-page

Automatic merge from submit-queue.

Bug 1538006 - Improve error page when console not installed

Adds a (very) basic error page for when the console is not installed.

Suggestions to make this better? It's hard to get specific in the error description since it's a generic service proxy.

Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1538006

![screen shot 2018-02-20 at 12 06 51 pm](https://user-images.githubusercontent.com/1167259/36438040-a971f8c4-1636-11e8-9b2c-deebf32eadab.png)

/assign @deads2k 
@jwforres @smarterclayton FYI

Comment 2 Samuel Padgett 2019-06-04 20:07:13 UTC
This was fixed in 3.9, but the bug did not get properly closed.


Note You need to log in before you can comment on or make changes to this bug.