Bug 1538062 - networking-ovn unit tests fail
Summary: networking-ovn unit tests fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Daniel Alvarez Sanchez
QA Contact: Arie Bregman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-24 12:01 UTC by Arie Bregman
Modified: 2019-09-09 16:30 UTC (History)
7 users (show)

Fixed In Version: python-networking-ovn-4.0.0-0.20180123151533.a60921a.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:43:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 526677 None None None 2018-01-24 16:18:01 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:44:09 UTC

Description Arie Bregman 2018-01-24 12:01:13 UTC
Description of problem:

Several unit tests fail with the following traceback:

Captured traceback:
~~~~~~~~~~~~~~~~~~~
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/neutron/tests/base.py", line 132, in func
        return f(self, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/mock/mock.py", line 1305, in patched
        return func(*args, **keywargs)
      File "networking_ovn/tests/unit/l3/test_l3_ovn.py", line 783, in test_update_floatingip_associate_distributed
        self.l3_inst.update_floatingip(self.context, 'id', 'floatingip')
      File "networking_ovn/l3/l3_ovn.py", line 298, in update_floatingip
        previous_fip = self._make_floatingip_dict(fip_db)
      File "/usr/lib/python2.7/site-packages/neutron/db/l3_db.py", line 1056, in _make_floatingip_dict
        'tenant_id': floatingip.project_id,
    AttributeError: 'FakeResource' object has no attribute 'project_id'


Version-Release number of selected component (if applicable): Latest networking-ovn source


How reproducible: 100%


Steps to Reproduce:
1. Clone networking-ovn
2. checkout osp 13 branch
3. Run tox -e py27

Comment 8 errata-xmlrpc 2018-06-27 13:43:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.