Bug 1538172 - [UPGRADE] Fail to update package - openstack-dashboard package conflict
Summary: [UPGRADE] Fail to update package - openstack-dashboard package conflict
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-24 15:10 UTC by Yurii Prokulevych
Modified: 2018-06-27 13:44 UTC (History)
11 users (show)

Fixed In Version: python-django-horizon-13.0.1-0.20180323102048.4dd4ef0.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:43:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 11869 None None None 2018-02-08 14:01:06 UTC
RDO 12120 None None None 2018-02-13 11:07:52 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:44:09 UTC

Description Yurii Prokulevych 2018-01-24 15:10:04 UTC
Description of problem:
-----------------------
Attempt to run upgrade of controller failed on yum update:

Transaction check error:
  file /usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.d from install of openstack-dashboard-1:13.0.0-0.20180104003946.el7ost.noarch conflicts with file from package openstack-dashboard-1:12.0.0-4.el7ost.noarch


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-dashboard-theme-12.0.0-3.el7ost.noarch
openstack-dashboard-12.0.0-4.el7ost.noarch


How reproducible:
-----------------
so far 100%


Steps to Reproduce:
-------------------
1. Upgrade uc from rhos-12 to rhos-13(with workarounds)
2. Apply workaround for oc upgrade
3. Install rhos-13 repos on oc nodes
4. openstack overcloud upgrade --nodes controller-1

Actual results:
---------------
Upgrade attempt fails

Expected results:
-----------------
Upgrade attempt succeeds

Comment 1 Radomir Dopieralski 2018-02-07 17:49:17 UTC
I'm trying to figure out what is wrong with the RPM here — a package you are updating should not normally generate conflict with the package you are updating it with.

I can see that the spec file for OSP13 has some differences with OSP12, I'm trying to figure out now which one of them is responsible for this problem.

The file in question is a symlink. In OSP12 it points to 

local_settings.d -> ../../../../../etc/openstack-dashboard/local_settings.d

Comment 2 Radomir Dopieralski 2018-02-07 17:56:22 UTC
In OSP13 the symlink is missing, and it's instead a directory.

Comment 3 Radomir Dopieralski 2018-02-07 17:57:20 UTC
In addition, the synlink to local_settings.py is wrong:

local_settings.py -> ../../../../..//etc/openstack-dashboard/local_settings

(note the extra slash)

Comment 4 Radomir Dopieralski 2018-02-07 17:58:44 UTC
The new spec is also missing those lines:

Requires:   openstack-dashboard-theme >= 1:12.0
Provides:    python2-django-horizon = %{epoch}:%{version}-%{release}

Although those are not immediately related to this issue.

Comment 5 Marios Andreou 2018-03-16 15:26:00 UTC
hitting this today, whilst trying to upgrade controller for P..Queens. It can be reproduced by just running yum update [0] on the node itself (during the upgrade it failed on the yum update task for the same reason).

Note that there was no openstack-dashboard installed, just sanity checked rpm -qa | grep dashboard [nope]

We are explicitly removing it during the upgrade init as a workaround for this BZ https://review.openstack.org/#/c/535859/15/doc/source/install/post_deployment/upgrade.rst@753

But I still hit this. The workaround for now was to add skip_broken=1 in yum.conf and it can update by skipping the heat-* packages [1] and perform the yum update 



[0] 
<snip>
---> Package teamd.x86_64 0:1.25-6.el7_4.3 will be an update
--> Running transaction check
---> Package openstack-dashboard.noarch 1:13.0.0-0.20180304122741.d4c1c29.el7.centos will be installed
--> Processing Dependency: openstack-dashboard-theme >= 1:13.0.0-0.20180304122741.d4c1c29.el7.centos for package: 1:openstack-dashboard-13.0.0-0.20180304122741.d4c1c29.el7.centos.noarch
---> Package openstack-heat-common.noarch 1:10.0.0-0.20180123134729.85a3e98.el7.centos will be updated
--> Processing Dependency: openstack-heat-common = 1:10.0.0-0.20180123134729.85a3e98.el7.centos for package: 1:openstack-heat-api-cloudwatch-10.0.0-0.20180123134729.85a3e98.el7.centos.noarch
---> Package openstack-sahara-image-pack.noarch 1:8.0.1-0.20180302152824.4e35c08.el7.centos will be installed
---> Package python-jwt.noarch 0:1.4.0-3.el7 will be installed
---> Package python2-glareclient.noarch 0:0.5.2-0.20180213103058.6da299f.el7.centos will be installed
---> Package python2-munch.noarch 0:2.2.0-2.el7 will be installed
---> Package python2-octaviaclient.noarch 0:1.4.0-0.20180209165356.830e49f.el7.centos will be installed
---> Package python2-tackerclient.noarch 0:0.11.0-0.20180209170617.8509a59.el7.centos will be installed
--> Running transaction check
---> Package openstack-dashboard-theme.noarch 1:13.0.0-0.20180304122741.d4c1c29.el7.centos will be installed
---> Package openstack-heat-common.noarch 1:10.0.0-0.20180123134729.85a3e98.el7.centos will be updated
--> Processing Dependency: openstack-heat-common = 1:10.0.0-0.20180123134729.85a3e98.el7.centos for package: 1:openstack-heat-api-cloudwatch-10.0.0-0.20180123134729.85a3e98.el7.centos.noarch
--> Finished Dependency Resolution
Error: Package: 1:openstack-heat-api-cloudwatch-10.0.0-0.20180123134729.85a3e98.el7.centos.noarch (@delorean)
           Requires: openstack-heat-common = 1:10.0.0-0.20180123134729.85a3e98.el7.centos
           Removing: 1:openstack-heat-common-10.0.0-0.20180123134729.85a3e98.el7.centos.noarch (@delorean)
               openstack-heat-common = 1:10.0.0-0.20180123134729.85a3e98.el7.centos
           Updated By: 1:openstack-heat-common-10.0.0-0.20180305133443.e46dbbb.el7.centos.noarch (delorean)
               openstack-heat-common = 1:10.0.0-0.20180305133443.e46dbbb.el7.centos
 You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
openstack-manila-ui-2.12.1-0.20180118225254.28a96c3.el7.centos.noarch has missing requires of openstack-dashboard >= ('1', '13.0.0', None)
openstack-neutron-lbaas-ui-4.0.0-0.20180123181022.17a57d9.el7.centos.noarch has missing requires of openstack-dashboard >= ('0', '9.0.0', None)
openstack-sahara-ui-8.0.0-0.20180123103525.5f60618.el7.centos.noarch has missing requires of openstack-dashboard >= ('1', '13.0.0', None)
[root@overcloud-novacompute-0 heat-admin]# vi /etc/yum.conf 


[1]
crudini  --set /etc/yum.conf main skip_broken 1

Skipped (dependency problems):
 openstack-heat-api                           noarch        1:10.0.0-0.20180305133443.e46dbbb.el7.centos           delorean                        16 k
 openstack-heat-api-cfn                       noarch        1:10.0.0-0.20180305133443.e46dbbb.el7.centos           delorean                        16 k
 openstack-heat-common                        noarch        1:10.0.0-0.20180305133443.e46dbbb.el7.centos           delorean                       1.7 M
 openstack-heat-engine                        noarch        1:10.0.0-0.20180305133443.e46dbbb.el7.centos           delorean                        15 k
 python2-octaviaclient                        noarch        1.4.0-0.20180209165356.830e49f.el7.centos              delorean                        56 k

Comment 6 Radomir Dopieralski 2018-03-16 21:34:29 UTC
The patches are in review. As soon as they are merged and a new version is imported from RDO, the issue will be fixed.

Comment 7 Radomir Dopieralski 2018-03-28 07:59:16 UTC
The fixes didn't land yet in RDO, but we made them downstream to have something to work on.

Comment 8 Marios Andreou 2018-03-28 11:16:38 UTC
also seen with slight variation on the undercloud here http://logs.openstack.org/36/554536/1/check/tripleo-ci-centos-7-undercloud-upgrades/ac53276/logs/undercloud/home/zuul/undercloud_upgrade.log.txt.gz 


--> Finished Dependency Resolution
Error: Package: 1:openstack-heat-monolith-10.0.0-0.20180305133443.e46dbbb.el7.centos.noarch (delorean)
           Requires: openstack-heat-common = 1:10.0.0-0.20180305133443.e46dbbb.el7.centos
           Installed: 1:openstack-heat-common-10.0.1-0.20180302152334.c3bd928.el7.centos.noarch (@delorean)
               openstack-heat-common = 1:10.0.1-0.20180302152334.c3bd928.el7.centos
           Available: 1:openstack-heat-common-10.0.0-0.20180305133443.e46dbbb.el7.centos.noarch (delorean)
               openstack-heat-common = 1:10.0.0-0.20180305133443.e46dbbb.el7.centos
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 9 Radomir Dopieralski 2018-03-28 11:31:55 UTC
Marios, I don't think that one is related to Horizon.

Comment 10 Jose Luis Franco 2018-03-28 12:55:04 UTC
A Launchpad bug has been opened related to the issue discribed in comment #8: https://bugs.launchpad.net/tripleo/+bug/1759560

Comment 12 Radomir Dopieralski 2018-04-11 18:47:32 UTC
I verified that upgrading to rhel-osp-13-puddle-2018-04-10-dot2 no longer causes that error.

Comment 18 errata-xmlrpc 2018-06-27 13:43:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.