Bug 1538211 - Use devtoolset-7 to bring darktable 2.4 into EPEL7
Summary: Use devtoolset-7 to bring darktable 2.4 into EPEL7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: darktable
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Germano Massullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1520385 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-24 16:00 UTC by Germano Massullo
Modified: 2018-05-11 19:58 UTC (History)
4 users (show)

Fixed In Version: darktable-2.4.3-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-11 19:58:11 UTC


Attachments (Terms of Use)

Description Germano Massullo 2018-01-24 16:00:53 UTC
Description of problem:
Personal reminder.
Implement centos-release-scl and devtoolset-7-toolchain usage to bring gcc >= 5.0 into build root.
gcc >= 5.0 is a minimum requirement for darktable 2.4.

https://src.fedoraproject.org/cgit/rpms/chromium.git/tree/chromium.spec
seems to be a good example of devtoolset-7-toolchain usage

Comment 1 Germano Massullo 2018-01-24 23:00:20 UTC
spec file I am working on:
https://germano.fedorapeople.org/canc/darktable-epel/darktable.spec

Comment 2 Germano Massullo 2018-01-24 23:01:36 UTC
*** Bug 1520385 has been marked as a duplicate of this bug. ***

Comment 3 Germano Massullo 2018-01-24 23:10:03 UTC
Rex Dieter told me that scl's devtoolset is not available in epel.
More infos should be available in epel-devel archives.
Copr instead should not have such limitation

Comment 5 Germano Massullo 2018-03-10 12:49:31 UTC
Oliver, when you will have some free time, could you please investigate on devtoolset6 usage, in order to be able to use gcc >= 5?
The mailing list discussion has reached some interesting points

Best regards

Comment 6 Fedora Update System 2018-04-17 18:12:26 UTC
darktable-2.4.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-466b7cdb4d

Comment 7 Fedora Update System 2018-04-18 02:13:15 UTC
darktable-2.4.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-466b7cdb4d

Comment 9 Fedora Update System 2018-04-19 08:43:36 UTC
darktable-2.4.2-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-074d6d3893

Comment 10 Fedora Update System 2018-04-19 16:59:25 UTC
darktable-2.4.2-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-074d6d3893

Comment 11 Fedora Update System 2018-04-25 17:05:41 UTC
darktable-2.4.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-3ef3bfb178

Comment 12 Fedora Update System 2018-04-27 05:09:02 UTC
darktable-2.4.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-3ef3bfb178

Comment 13 Fedora Update System 2018-05-11 19:58:11 UTC
darktable-2.4.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.