Bug 1538217 - AAA - setup script errors out solely on the exit status of dig command.
Summary: AAA - setup script errors out solely on the exit status of dig command.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-extension-aaa-ldap
Version: 4.1.8
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.2
: ---
Assignee: Ondra Machacek
QA Contact: Gonza
URL:
Whiteboard:
: 1537265 (view as bug list)
Depends On:
Blocks: 1540133
TreeView+ depends on / blocked
 
Reported: 2018-01-24 16:17 UTC by Anitha Udgiri
Modified: 2019-10-07 12:30 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-extension-aaa-ldap-1.3.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1540133 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:35:42 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3352321 None None None 2018-02-13 17:45:49 UTC
Red Hat Product Errata RHEA-2018:1485 None None None 2018-05-15 17:36:13 UTC
oVirt gerrit 86799 None None None 2018-01-26 19:56:13 UTC

Description Anitha Udgiri 2018-01-24 16:17:53 UTC
Description of problem:
   When resolving for Global Catalog SRV records, the dig command used under the covers is able to obtain the records only for TCP communication and not UDP.

The script seems to determine this as failure to resolve anything and errors out.

Comment 3 Martin Perina 2018-01-30 10:40:51 UTC
*** Bug 1537265 has been marked as a duplicate of this bug. ***

Comment 6 Gonza 2018-02-26 10:34:52 UTC
Verified with:
ovirt-engine-extension-aaa-ldap-1.3.7-1.el7ev.noarch

Comment 9 errata-xmlrpc 2018-05-15 17:35:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1485

Comment 10 Franta Kust 2019-05-16 13:06:23 UTC
BZ<2>Jira Resync

Comment 11 Klaas Demter 2019-07-25 12:15:12 UTC
"When resolving for Global Catalog SRV records, the dig command used under the covers is able to obtain the records only for TCP communication and not UDP."
the +ignore command that was added does not change the lookup to tcp. I think you meant to use +vc or +tcp

Comment 12 Daniel Gur 2019-08-28 13:13:27 UTC
sync2jira

Comment 13 Daniel Gur 2019-08-28 13:17:40 UTC
sync2jira


Note You need to log in before you can comment on or make changes to this bug.