Bug 1538220 - [GSS] [OCP 3.4.1] openshift-sdn partially deletes openflow rules leading to "no route to host" for service
Summary: [GSS] [OCP 3.4.1] openshift-sdn partially deletes openflow rules leading to "...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.4.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Dan Winship
QA Contact: Meng Bo
URL:
Whiteboard:
: 1538227 (view as bug list)
Depends On: 1464191 1538227
Blocks: 1570394 1570395 1570396
TreeView+ depends on / blocked
 
Reported: 2018-01-24 16:24 UTC by Francesco Marchioni
Modified: 2018-07-30 19:09 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Incorrect management of OVS flows Consequence: If two nodes rebooted and swapped IP addresses when they came back up, then other nodes might become unable to send traffic to pods on one or both of those nodes. Fix: The code that manages OVS flows is now more careful to make the correct changes in cases of node IP reassignment. Result: Pod-to-pod traffic should continue to work correctly even after nodes swap IP addresses.
Clone Of: 1464191
: 1570394 (view as bug list)
Environment:
Last Closed: 2018-07-30 19:09:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:34 UTC
Origin (Github) 19080 None None None 2018-04-22 14:44:07 UTC

Comment 1 Ben Bennett 2018-01-29 14:40:05 UTC
*** Bug 1538227 has been marked as a duplicate of this bug. ***

Comment 7 Dan Winship 2018-04-22 14:44:07 UTC
Reporter has stated that they don't need a backport to 3.4, so I'm repurposing this bug for master/3.10, and will clone for 3.9, 3.8, and 3.7 backports.

https://github.com/openshift/origin/pull/19080
https://github.com/openshift/origin/pull/19273

Comment 9 Hongan Li 2018-05-16 08:08:40 UTC
verified in atomic-openshift-3.10.0-0.46.0.git.0.02bb86f.el7 and cookies has been added for the nodes in ovs flow as below:

OFPST_FLOW reply (OF1.3) (xid=0x2):
 cookie=0xcde0e385, duration=3822.038s, table=10, n_packets=3025, n_bytes=634211, priority=100,tun_src=172.18.5.45 actions=goto_table:30
 cookie=0xcde0e385, duration=3822.038s, table=50, n_packets=3, n_bytes=126, priority=100,arp,arp_tpa=10.129.0.0/16 actions=move:NXM_NX_REG0[]->NXM_NX_TUN_ID[0..31],set_field:172.18.5.45->tun_dst,output:1
 cookie=0xcde0e385, duration=3822.038s, table=90, n_packets=2271, n_bytes=266016, priority=100,ip,nw_dst=10.129.0.0/16 actions=move:NXM_NX_REG0[]->NXM_NX_TUN_ID[0..31],set_field:172.18.5.45->tun_dst,output:1

OS: Red Hat Enterprise Linux Server release 7.5 (Maipo)
kernel: Linux ip-172-18-2-86.ec2.internal 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 11 errata-xmlrpc 2018-07-30 19:09:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.