Bug 1538427 - Seeing timer errors in the rebalance logs
Summary: Seeing timer errors in the rebalance logs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On: 1542934
Blocks: 1467536
TreeView+ depends on / blocked
 
Reported: 2018-01-25 04:27 UTC by Mohit Agrawal
Modified: 2018-06-20 17:58 UTC (History)
10 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1467536
Environment:
Last Closed: 2018-06-20 17:58:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2018-01-25 04:42:34 UTC
REVIEW: https://review.gluster.org/19320 (rpc: Showing some unusual timer error logs during brick stop) posted (#1) for review on master by MOHIT AGRAWAL

Comment 2 Worker Ant 2018-01-30 09:35:24 UTC
COMMIT: https://review.gluster.org/19320 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- rpc: Showing some unusual timer error logs during brick stop

Solution: Update msg condition in gf_timer_call_after function
          to avoid the message

BUG: 1538427
Change-Id: I849e8e052a8259cf977fd5e7ff3aeba52f9b5f27
Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>

Comment 3 Shyamsundar 2018-06-20 17:58:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.