Bug 1538465 - Support MTU property with OVN networks
Summary: Support MTU property with OVN networks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-provider-ovn
Classification: oVirt
Component: provider
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.5
: ---
Assignee: Dominik Holler
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-25 07:10 UTC by Mor
Modified: 2018-07-31 15:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-31 15:25:06 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91394 0 None MERGED Add optional MTU parameter to network 2020-09-16 10:30:52 UTC
oVirt gerrit 91430 0 None MERGED Allow modification of network MTU value 2020-09-16 10:30:54 UTC

Description Mor 2018-01-25 07:10:27 UTC
Description of problem:
On OVN network, there should be an option to set or update the MTU as it is defined in the Neutron API. This could aid in scenarios where the MTU needs to be adjusted according to the environment configuration. 
Examples for use cases:
- Configuring Jumbo Frames (packet length > 1500), to improve network performance.
- Decrease the default MTU, according to the environment limitations (switch/router). 

Version-Release number of selected component (if applicable):
ovirt-provider-ovn-1.2.5-1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Update / Create OVN network

Actual results:
MTU property is not supported.

Expected results:
Should be supported.

Additional info:

Comment 1 Marcin Mirecki 2018-02-15 14:22:39 UTC
Related OVS bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1545290

Comment 2 Mor 2018-02-15 14:23:34 UTC
MTU value adjustment in the lab that solved the performance issue with 10GE:
- VM vNICs (through guest OS) - 8492
- vnets - 8492
- host NICs - 8492
- Switch ports that connects the host NICs - 9216 (but it could be less)

Comment 3 Mor 2018-02-15 14:40:51 UTC
Correction:
* the host NICs - 9000

On host:
# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovirtmgmt state UP mode DEFAULT qlen 1000
    link/ether 14:18:77:43:ef:0d brd ff:ff:ff:ff:ff:ff
3: em2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 14:18:77:43:ef:0e brd ff:ff:ff:ff:ff:ff
4: em3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 14:18:77:43:ef:0f brd ff:ff:ff:ff:ff:ff
5: em4: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 14:18:77:43:ef:10 brd ff:ff:ff:ff:ff:ff
6: p7p1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 00:0a:f7:8f:59:86 brd ff:ff:ff:ff:ff:ff
7: p7p2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 00:0a:f7:8f:59:87 brd ff:ff:ff:ff:ff:ff
8: p5p1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
    link/ether a0:36:9f:8f:37:00 brd ff:ff:ff:ff:ff:ff
9: p5p2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc mq state UP mode DEFAULT qlen 1000
    link/ether a0:36:9f:8f:37:02 brd ff:ff:ff:ff:ff:ff
40: ;vdsmdummy;: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether da:01:e9:c4:fb:13 brd ff:ff:ff:ff:ff:ff
41: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether 66:07:70:ca:dd:cb brd ff:ff:ff:ff:ff:ff
43: br-int: <BROADCAST,MULTICAST> mtu 8492 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether f6:3a:8e:6d:79:44 brd ff:ff:ff:ff:ff:ff
44: ovirtmgmt: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT qlen 1000
    link/ether 14:18:77:43:ef:0d brd ff:ff:ff:ff:ff:ff
57: genev_sys_6081: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 65470 qdisc noqueue master ovs-system state UNKNOWN mode DEFAULT qlen 1000
    link/ether 12:65:a9:b4:38:90 brd ff:ff:ff:ff:ff:ff
62: vethint0@vethouter1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 8492 qdisc noqueue master ovs-system state UP mode DEFAULT qlen 1000
    link/ether 8a:fd:5c:00:72:41 brd ff:ff:ff:ff:ff:ff
63: vethouter1@vethint0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 8492 qdisc noqueue state UP mode DEFAULT qlen 1000
    link/ether 52:d2:29:ab:79:12 brd ff:ff:ff:ff:ff:ff
72: vnet0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 8492 qdisc pfifo_fast master ovs-system state UNKNOWN mode DEFAULT qlen 1000
    link/ether fe:1a:4a:16:20:37 brd ff:ff:ff:ff:ff:ff
73: vnet1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovirtmgmt state UNKNOWN mode DEFAULT qlen 1000
    link/ether fe:1a:4a:16:20:3c brd ff:ff:ff:ff:ff:ff

Comment 4 Mor 2018-02-15 14:49:00 UTC
On the VM:
# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 8492 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether 00:1a:4a:16:20:37 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether 00:1a:4a:16:20:3c brd ff:ff:ff:ff:ff:ff

eth0 is the OVN vNIC

Comment 5 Michael Burman 2018-07-16 12:44:29 UTC
Verified on - 4.2.5.2_SNAPSHOT-79.gffafd93.0.scratch.master.el7ev

Comment 6 Sandro Bonazzola 2018-07-31 15:25:06 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.