Bug 15385 - Machine did not enable swap when necessary to install
Machine did not enable swap when necessary to install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-04 09:23 EDT by Joe Ceklosky
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-26 18:39:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Ceklosky 2000-08-04 09:23:12 EDT
The installer in TEXT mode will SEGV during the installation of the packages.
The laptop normally runs linux fine so it's an INSTALLER bug.
Comment 1 Alan Cox 2000-08-05 17:20:08 EDT
How much ram does it have ?
Comment 2 Joe Ceklosky 2000-08-06 11:22:46 EDT
The machine has 64 Megs of RAM.  Ram is never an issue with this machine.
It has always worked fine.
I will try and get more of the segV information.

Comment 3 Joe Ceklosky 2000-08-09 21:36:47 EDT
Anaconda is SEGVing

Opps:  0000
CPU:   0
EIP:   0010:[c0124ed4>]
EFLAGS:  00010206
{DUMP OF ALL REGISTERS)
Process anaconda (pid: 10, process nr: 10, stackpage=cfe1000)
{STACK TRACE-omitted)
Call Trace: (CALL STACK-omitted)



Unable to handle kernel paging reguest at virtual address 00002000
current->tss.cr3 = 03fe2000, %cr3 = 03fe2000
*pde = 00000000
Oops: 0000
(Rest of information)


The machine has 64 megs of RAM and 32 Meg of SWAP.  
----->IT DOES NOT HAVE ANY MEMORY PROBLEMS!  
I can compile the kernel a million times over.
Comment 4 Joe Ceklosky 2000-08-24 20:53:22 EDT
I tried the latest Rawhide release from August 11 and anaconda is still
segving on the install. 
 
EIP: <c011b4fa>
Call Trace:  <c0138f63> <c0120b10> <c012cdea> <c012d105> <c012d69a> <c010d0ce>
<c0123b2a>

Any thoughts?

The MEMORY is GOOD!

Do you need any other information?
Comment 5 Joe Ceklosky 2000-08-25 09:04:49 EDT
Just as a test I went back and tried the installer from Redhat 6.2 and the installer SEGVed too.  The installer in 6.1 is just fine.

The kernel is unable to handle a paging request which caused the installer to SEGV.  As I keep saying, MEMORY is fine. 
I can compile the kernel over and over again without a hitch.  Also there is plenty of memory, I have 64 Megs of RAM and 85
Megs of swap space at the time.

Is there anything else we can do to track this down?  It is SEGV's installing the packages (the screen with the progress bar
on it).  I get about 8 installed and acaconda dies with a SEGV.


Comment 6 Joe Ceklosky 2000-09-07 22:49:12 EDT
I did some more testing and forced the installer to turn swap on.   I think the
installer is causing
kernel to run out of memory.  The SEGV problem appears to happen when installing
the large
glibc package of 42 Megs.

If the installer finds a swap partition on the HD, you should just turn swap
on.  I will continue to test out my theory.

Comment 7 Michael Fulbright 2000-11-13 15:59:35 EST
Were you able to determine anything new?
Comment 8 Joe Ceklosky 2000-11-13 20:18:57 EST
I turned swap on and never had a problem.  If swap is available you should
allow the user to use it during the install.
Again I want to say, there are NO MEMORY problems with this laptop.
Comment 9 Michael Fulbright 2000-11-15 12:05:24 EST
I will make this into a enchancement request for the option to manually enable swap.

Just out of curiosity, when you boot into the 7.0 installer, and before you
start installing packages, if you goto virtual console 2 (CNTL-ALT-F2) and type
'cat /proc/meminfo', was does it report?
Comment 10 Joe Ceklosky 2000-11-15 23:02:18 EST
Yes it sees the machine has 64 Meg in it, which is correct.
Comment 11 Erik Troan 2001-01-12 12:42:28 EST
We are supposed to turn on all swap partitions as part of the install. Does your
swap partition have the correct type listed in fdisk?
Comment 12 Joe Ceklosky 2001-01-16 20:52:23 EST
The swap partition does have the correct type.
Comment 13 Michael Fulbright 2001-02-08 16:04:27 EST
I cannot explain the problem you are having. If you put "mem=32M' on your boot
command line (and have at least 64M of swap configured) then the installer
should automatically enable swap. I have not seen this problem reported for
other systems with 64M. Hopefully this workaround will be adeqaute.

Note You need to log in before you can comment on or make changes to this bug.