Bug 1538529 - The "Save Changes" button should be disabled when there are no changes to save
Summary: The "Save Changes" button should be disabled when there are no changes to save
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-25 08:56 UTC by Udi
Modified: 2018-06-27 13:44 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-ui-8.3.1-0.20180303225336.57e3d96.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:43:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 544000 None master: MERGED tripleo-ui: Convert Role detail dialog to redux-form (I302c24b4cb4e94230c213305a536fa9e6ad09296) 2018-03-21 13:48:56 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:44:09 UTC

Description Udi 2018-01-25 08:56:12 UTC
Description of problem:
In the edit role dialog, the "Save Changes" button is initially enabled even though the user hasn't yet entered any changes and there is nothing to save. It also remains enabled after the 1st save, and only after the 2nd save it becomes disabled.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.4.3-4.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Edit a role
2. Notice that the "Save Changes" button is initially enabled
3. Change a setting (for example the flavor) and save
4. The "Save Changes" button is still enabled right after the save, as if the changes were not really saved
5. Click "Save Changes" again


Actual results:
The "Save Changes" button becomes disabled only after the 2nd save

Comment 6 Udi 2018-04-09 12:39:53 UTC
Verified in: openstack-tripleo-ui-8.3.1-2.el7ost.noarch

Comment 8 errata-xmlrpc 2018-06-27 13:43:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.