Bug 1538644 - Undercloud Zaqar's log full of QueueDoesNotExist: Queue tripleo-ui-logging does not exist for project
Summary: Undercloud Zaqar's log full of QueueDoesNotExist: Queue tripleo-ui-logging do...
Keywords:
Status: CLOSED DUPLICATE of bug 1552008
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 13.0 (Queens)
Assignee: Honza Pokorny
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-25 14:09 UTC by Pavel Sedlák
Modified: 2018-03-26 15:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-22 09:33:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
rpm -qa (41.43 KB, text/plain)
2018-01-25 14:14 UTC, Pavel Sedlák
no flags Details
/var/log/zaqar/zaqar.log (38.71 KB, text/plain)
2018-01-25 14:15 UTC, Pavel Sedlák
no flags Details
openstack undercloud install output (265.72 KB, text/plain)
2018-01-25 14:16 UTC, Pavel Sedlák
no flags Details
openstack overcloud deploy script used (793 bytes, text/plain)
2018-01-25 14:17 UTC, Pavel Sedlák
no flags Details
openstack overcloud deploy output (153.47 KB, text/plain)
2018-01-25 14:17 UTC, Pavel Sedlák
no flags Details

Description Pavel Sedlák 2018-01-25 14:09:32 UTC
After fresh deployment of OSP13 with tripleo (using command line, containers images prepare/overcloud deploy style)
I've noticed that /var/log/zaqar/zaqar.log file is filling with messages like, one every hour it seems:

> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages [req-a8e13d9c-af48-44f5-acf9-f2ba391f336c a94154226d5e42cba4f283d6d6f4743d 3e3dbdf4197340ec8eb9e94adf2a9415 - default default] Queue tripleo-ui-logging does not exist for project 3e3dbdf4197340ec8eb9e94adf2a9415: QueueDoesNotExist: Queue tripleo-ui-logging does not exist for project 3e3dbdf4197340ec8eb9e94adf2a9415
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages Traceback (most recent call last):
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages   File "/usr/lib/python2.7/site-packages/zaqar/transport/wsgi/v2_0/messages.py", line 105, in _get
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages     project_id)
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages   File "/usr/lib/python2.7/site-packages/zaqar/common/pipeline.py", line 97, in consumer
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages     tmp = target(*args, **kwargs)
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages   File "/usr/lib/python2.7/site-packages/zaqar/storage/sqlalchemy/queues.py", line 69, in get_metadata
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages     raise errors.QueueDoesNotExist(name, project)
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages QueueDoesNotExist: Queue tripleo-ui-logging does not exist for project 3e3dbdf4197340ec8eb9e94adf2a9415
> 2018-01-24 18:00:02.703 1619 ERROR zaqar.transport.wsgi.v2_0.messages 

Not sure what impact of that is (did not caused any trouble issue for me it seems),
although it's recorded as ERROR and with traceback seems as bug to me.

Also the uuid of missing queue is uuid of 'admin' project:
> $ openstack project list
> +----------------------------------+------------------------------------------------------------------+
> | ID                               | Name                                                             |
> +----------------------------------+------------------------------------------------------------------+
> | 3e3dbdf4197340ec8eb9e94adf2a9415 | admin                                                            |
> | be379b4a02de4e8a8178ad345bd0f25e | 3e3dbdf4197340ec8eb9e94adf2a9415-a48fc8f2-a841-4057-81e2-25093c9 |
> | f6f0e4f2c6d549498f7519c6ee492089 | service                                                          |
> +----------------------------------+------------------------------------------------------------------+



Not sure from where these requests are comming, so some of installed packages:
> openstack-tripleo-common.noarch           8.3.1-0.20180103233643.el7ost              @rhelosp-13.0-puddle
> openstack-tripleo-heat-templates.noarch   8.0.0-0.20180103192341.el7ost              @rhelosp-13.0-puddle
> openstack-tripleo-ui.noarch               7.4.3-4.el7ost                             @rhelosp-13.0-puddle
> openstack-zaqar.noarch                    1:6.0.0-0.20171229101800.764bbb9.el7ost    @rhelosp-13.0-puddle
> puppet-zaqar.noarch                       12.1.1-0.20171226064209.d7796e9.el7ost     @rhelosp-13.0-puddle
> python2-zaqarclient.noarch                1.8.0-0.20171221131422.a2bc819.el7ost      @rhelosp-13.0-puddle

Comment 1 Pavel Sedlák 2018-01-25 14:14:48 UTC
Created attachment 1386099 [details]
rpm -qa

Comment 2 Pavel Sedlák 2018-01-25 14:15:14 UTC
Created attachment 1386100 [details]
/var/log/zaqar/zaqar.log

Comment 3 Pavel Sedlák 2018-01-25 14:16:22 UTC
Created attachment 1386101 [details]
openstack undercloud install output

Comment 4 Pavel Sedlák 2018-01-25 14:17:09 UTC
Created attachment 1386102 [details]
openstack overcloud deploy script used

Comment 5 Pavel Sedlák 2018-01-25 14:17:32 UTC
Created attachment 1386103 [details]
openstack overcloud deploy output

Comment 9 Honza Pokorny 2018-03-22 09:33:37 UTC

*** This bug has been marked as a duplicate of bug 1552008 ***


Note You need to log in before you can comment on or make changes to this bug.