Bug 15387 - vim system wide init file location
Summary: vim system wide init file location
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-04 13:29 UTC by giulioo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 13:29:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2000-08-04 13:29:31 UTC
man vim, "FILES:" section
says:
/usr/share/vim/vimrc
                   System wide Vim initializations.


but it seems that file is not used anymore (maybe the same is true for 
/usr/share/vim/gvimrc but I can't test it), in fact:

:version
says something different:
system vimrc file: "/usr/share/vim/vim57/macros/vimrc"

rh6.1 used 
system vimrc file: "$VIM/vimrc"
and on my system it refers to /usr/share/vim/vimrc

Comment 1 Bernhard Rosenkraenzer 2000-08-04 13:50:33 UTC
I've fixed the man page in 5.7-4.
We've decided to move vimrc to the version-specific directory because vim 6.0
needs slightly different options than 5.7.



Note You need to log in before you can comment on or make changes to this bug.